summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-03-19 09:26:02 +0100
committerRemi Collet <fedora@famillecollet.com>2015-03-19 09:26:02 +0100
commit5da6ceae17df0318b8a7a60eb66ee182c4b8b47d (patch)
tree38a46b1df45cf644ea73cb06de9db1d52ee30165
parentdfd86761c1891a08c2fcc8ea8a167f7285fc8ed1 (diff)
PHP 5.4.23
-rw-r--r--php-odbc.patch40
-rw-r--r--php.spec11
-rwxr-xr-xstrip.sh12
3 files changed, 15 insertions, 48 deletions
diff --git a/php-odbc.patch b/php-odbc.patch
deleted file mode 100644
index 12bff99..0000000
--- a/php-odbc.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From 89f86119d612d539a4ec189aff4d3c077cb608a1 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@php.net>
-Date: Sun, 8 Mar 2015 07:34:51 +0100
-Subject: [PATCH] Fix odbc build as shared
-
-Broken since a41aa46759d20e23af92df00b917ca66c6102412
----
- ext/odbc/config.m4 | 9 +++++----
- 1 file changed, 5 insertions(+), 4 deletions(-)
-
-diff --git a/ext/odbc/config.m4 b/ext/odbc/config.m4
-index f79c461..9555efd 100644
---- a/ext/odbc/config.m4
-+++ b/ext/odbc/config.m4
-@@ -99,6 +99,11 @@ AC_DEFUN([PHP_ODBC_FIND_EMPRESS_BCS_LIBS],[
- dnl
- dnl configure options
- dnl
-+
-+PHP_ARG_WITH(odbcver,,
-+[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
-+ Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
-+
- if test -z "$ODBC_TYPE"; then
- PHP_ARG_WITH(adabas,,
- [ --with-adabas[=DIR] Include Adabas D support [/usr/local]])
-@@ -490,10 +495,6 @@ PHP_ARG_WITH(dbmaker,,
- fi
- fi
-
--PHP_ARG_WITH(odbcver,,
--[ --with-odbcver[=HEX] Force support for the passed ODBC version. A hex number is expected, default 0x0300.
-- Use the special value of 0 to prevent an explicit ODBCVER to be defined. ], 0x0300)
--
- if test "no" != "$PHP_ODBCVER"; then
- if test "$PHP_ODBCVER" != "0"; then
- AC_DEFINE_UNQUOTED(ODBCVER, $PHP_ODBCVER, [ The highest supported ODBC version ])
---
-2.1.4
-
diff --git a/php.spec b/php.spec
index 6eb17af..c1459bb 100644
--- a/php.spec
+++ b/php.spec
@@ -127,12 +127,12 @@
%global db_devel libdb-devel
%endif
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: 5.5.23
-Release: 0.1.RC1%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -183,7 +183,6 @@ Patch47: php-5.4.9-phpinfo.patch
Patch91: php-5.3.7-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-odbc.patch
# Security fixes (200+)
@@ -856,8 +855,6 @@ support for using the enchant library to PHP.
%patch46 -p1 -b .fixheader
%patch47 -p1 -b .phpinfo
-%patch100 -p1 -b .obbc
-
%patch91 -p1 -b .remi-oci8
# upstream patches
@@ -1735,6 +1732,10 @@ fi
%changelog
+* Thu Mar 19 2015 Remi Collet <remi@fedoraproject.org> 5.5.23-1
+- Update to 5.5.23
+ http://www.php.net/releases/5_5_23.php
+
* Sun Mar 8 2015 Remi Collet <remi@fedoraproject.org> 5.5.23-0.1.RC1
- update to 5.5.23RC1
diff --git a/strip.sh b/strip.sh
index 5939bec..45bfabd 100755
--- a/strip.sh
+++ b/strip.sh
@@ -4,7 +4,13 @@ if [ -z "$1" ]; then
echo "usage $0 version"
exit 1;
fi
-if [ ! -f php-$1.tar.xz ]; then
+if [ -f php-$1.tar.xz ]; then
+ arc=php-$1.tar.xz
+
+elif [ -f php-$1.tar.gz ]; then
+ arc=php-$1.tar.gz
+
+else
echo "missing php-$1.tar.xz archive"
exit 2;
fi
@@ -12,13 +18,13 @@ old=$(mktemp)
new=$(mktemp)
echo "Untar..."
-tar xf php-$1.tar.xz
+tar xf $arc
rm -rf php-$1/ext/json
echo "Tar..."
tar cJf php-$1-strip.tar.xz php-$1
echo "Diff..."
-tar tf php-$1.tar.xz | sort >$old
+tar tf $arc | sort >$old
tar tf php-$1-strip.tar.xz | sort >$new
diff $old $new