summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-03-26 09:36:55 +0100
committerRemi Collet <fedora@famillecollet.com>2015-03-26 09:36:55 +0100
commit7bf67498ce180e9aa96d30e2f1b550a58476c0c7 (patch)
tree00e0de2bd70dbc9edcb75050bcef348050f90470
parentb5aea0a0ba5e1bdfc440f3f645130e051abda780 (diff)
php54: fix unowned directories
-rw-r--r--php54.spec24
1 files changed, 19 insertions, 5 deletions
diff --git a/php54.spec b/php54.spec
index 3965c43..3e40725 100644
--- a/php54.spec
+++ b/php54.spec
@@ -15,8 +15,8 @@
Summary: Package that installs PHP 5.4
Name: %scl_name
-Version: 2.0
-Release: 4%{?dist}
+Version: 2.1
+Release: 1%{?dist}
Group: Development/Languages
License: GPLv2+
@@ -33,9 +33,9 @@ BuildRequires: iso-codes
BuildRequires: environment-modules
%endif
-Requires: %{?scl_prefix}php-common%{?_isa} >= 5.4.38
+Requires: %{?scl_prefix}php-common%{?_isa} >= 5.4.39
Requires: %{?scl_prefix}php-cli%{?_isa}
-Requires: %{?scl_prefix}php-pear >= 1:1.9.5-8
+Requires: %{?scl_prefix}php-pear >= 1:1.9.5-9
Requires: %{?scl_name}-runtime%{?_isa} = %{version}-%{release}
%description
@@ -133,6 +133,11 @@ install -D -m 644 envmod %{buildroot}%{_scl_scripts}/%{scl_name}
install -D -m 644 scldev %{buildroot}%{macrosdir}/macros.%{scl_name_base}-scldevel
install -D -m 644 %{scl_name}.7 %{buildroot}%{_mandir}/man7/%{scl_name}.7
+install -d -m 755 %{buildroot}%{_datadir}/licenses
+install -d -m 755 %{buildroot}%{_datadir}/doc/pecl
+install -d -m 755 %{buildroot}%{_datadir}/tests/pecl
+install -d -m 755 %{buildroot}%{_localstatedir}/lib/pear/pkgxml
+
%scl_install
# Add the scl_package_override macro
@@ -146,6 +151,8 @@ if [ "%{_root_sysconfdir}/rpm" != "%{macrosdir}" ]; then
fi
+%{!?_licensedir:%global license %%doc}
+
%files
@@ -155,9 +162,12 @@ fi
%files runtime -f filesystem
%endif
%defattr(-,root,root)
-%doc README LICENSE
+%license LICENSE
+%doc README
%scl_files
%{_mandir}/man7/%{scl_name}.*
+%{?_licensedir:%{_datadir}/licenses}
+%{_datadir}/tests
%files build
@@ -171,6 +181,10 @@ fi
%changelog
+* Wed Mar 25 2015 Remi Collet <remi@fedoraproject.org> 2.1-1
+- fix licenses location
+- own directories for pecl packages
+
* Mon Mar 2 2015 Remi Collet <remi@fedoraproject.org> 2.0-4
- static environement module file instead of
generated one, because of https://bugzilla.redhat.com/1197321