summaryrefslogtreecommitdiffstats
path: root/roundcubemail.spec
diff options
context:
space:
mode:
Diffstat (limited to 'roundcubemail.spec')
-rw-r--r--roundcubemail.spec80
1 files changed, 54 insertions, 26 deletions
diff --git a/roundcubemail.spec b/roundcubemail.spec
index 13c89ad..40c3f3b 100644
--- a/roundcubemail.spec
+++ b/roundcubemail.spec
@@ -18,8 +18,8 @@
%else
%global with_phpfpm 0
%endif
-%global upstream_version 1.6
-%global upstream_prever beta
+%global upstream_version 1.6.6
+#global upstream_prever rc
%global roundcubedir %{_datadir}/roundcubemail
%global _logdir /var/log
@@ -39,9 +39,11 @@ Summary: Round Cube Webmail is a browser-based multilingual IMAP client
# https://github.com/pear/Crypt_GPG
# http://jqueryui.com/
# http://www.tinymce.com/
-License: GPLv3+ with exceptions and GPLv3+ and GPLv2 and LGPLv2+ and CC-BY-SA and MIT and BSD and PHP
+License: GPL-3.0-or-later AND GPL-2.0-only AND LGPL-2.0-or-later AND CC-BY-SA-3.0 AND MIT AND BSD-2-Clause AND BSD-3-Clause AND PHP-3.01
URL: http://www.roundcube.net
Source0: https://github.com/roundcube/roundcubemail/releases/download/%{upstream_version}%{?upstream_prever:-%{upstream_prever}}/roundcubemail-%{upstream_version}%{?upstream_prever:-%{upstream_prever}}-complete.tar.gz
+Source8: https://github.com/roundcube/roundcubemail/releases/download/%{upstream_version}%{?upstream_prever:-%{upstream_prever}}/roundcubemail-%{upstream_version}%{?upstream_prever:-%{upstream_prever}}-complete.tar.gz.asc
+Source9: https://roundcube.net/download/pubkey.asc
Source1: roundcubemail.httpd
Source3: roundcubemail.nginx
@@ -52,11 +54,10 @@ Source5: roundcubemail-bundled.php
# Non-upstreamable: Adjusts config path to Fedora policy
Patch1: roundcubemail-1.6-confpath.patch
-# See https://github.com/roundcube/roundcubemail/pull/846
-Patch2: roundcubemail-1.6-legacy.patch
BuildArch: noarch
+BuildRequires: gnupg2
BuildRequires: php(language) >= 7.3
# For test
BuildRequires: php-cli
@@ -147,35 +148,35 @@ Provides: bundled(js-tinymce-langs) = 5.8.2
# License BSD
Provides: bundled(php-pear-auth-sasl) = v1.1.0
# License BSD-2-Clause
-Provides: bundled(php-bacon-bacon-qr-code) = 2.0.6
-Provides: bundled(php-dasprid-enum) = 1.0.3
+Provides: bundled(php-bacon-bacon-qr-code) = 2.0.8
+Provides: bundled(php-dasprid-enum) = 1.0.5
Provides: bundled(php-pear-console-getopt) = v1.4.3
-Provides: bundled(php-pear-net-sieve) = 1.4.5
-Provides: bundled(php-pear-net-smtp) = 1.10.0
+Provides: bundled(php-pear-net-sieve) = 1.4.6
+Provides: bundled(php-pear-net-smtp) = 1.10.1
Provides: bundled(php-pear-pear-exception) = v1.0.2
# License BSD-3-Clause
Provides: bundled(php-pear-mail-mime) = 1.10.11
-Provides: bundled(php-pear-pear-core-minimal) = v1.10.11
+Provides: bundled(php-pear-pear-core-minimal) = v1.10.14
# License GPL-2.0
-Provides: bundled(php-roundcube-rtf-html-php) = v2.1
+Provides: bundled(php-roundcube-rtf-html-php) = v2.2
# License GPL-3.0+
-Provides: bundled(php-kolab-net-ldap3) = v1.1.3
-Provides: bundled(php-roundcube-plugin-installer) = 0.3.1
+Provides: bundled(php-kolab-net-ldap3) = v1.1.5
+Provides: bundled(php-roundcube-plugin-installer) = 0.3.2
# License LGPL-2.1
-Provides: bundled(php-pear-crypt-gpg) = v1.6.7
+Provides: bundled(php-pear-crypt-gpg) = v1.6.8
# License LGPL-3.0
-Provides: bundled(php-pear-net-ldap2) = v2.2.0
+Provides: bundled(php-pear-net-ldap2) = v2.3.0
# License MIT
-Provides: bundled(php-guzzlehttp-guzzle) = 7.4.1
-Provides: bundled(php-guzzlehttp-promises) = 1.5.1
-Provides: bundled(php-guzzlehttp-psr7) = 2.1.0
-Provides: bundled(php-masterminds-html5) = 2.7.5
-Provides: bundled(php-pear-console-commandline) = v1.2.4
-Provides: bundled(php-psr-http-client) = 1.0.1
-Provides: bundled(php-psr-http-factory) = 1.0.1
-Provides: bundled(php-psr-http-message) = 1.0.1
+Provides: bundled(php-guzzlehttp-guzzle) = 7.8.1
+Provides: bundled(php-guzzlehttp-promises) = 2.0.2
+Provides: bundled(php-guzzlehttp-psr7) = 2.6.2
+Provides: bundled(php-masterminds-html5) = 2.7.6
+Provides: bundled(php-pear-console-commandline) = v1.2.6
+Provides: bundled(php-psr-http-client) = 1.0.3
+Provides: bundled(php-psr-http-factory) = 1.0.2
+Provides: bundled(php-psr-http-message) = 2.0
Provides: bundled(php-ralouphie-getallheaders) = 3.0.3
-Provides: bundled(php-symfony-deprecation-contracts) = v2.2.0
+Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
# License PHP License
Provides: bundled(php-pear-net-socket) = v1.2.2
@@ -192,9 +193,10 @@ CSS 2.
%prep
+%{?gpgverify: %{gpgverify} --keyring=%{SOURCE9} --signature=%{SOURCE8} --data=%{SOURCE0}}
+
%setup -q -n roundcubemail-%{upstream_version}%{?upstream_prever:-%{upstream_prever}}
-%patch1 -p1 -b .rpm
-%patch2 -p1
+%patch -P1 -p1 -b .rpm
: PHP bundled libraries
php %{SOURCE5} vendor/composer/installed.json
@@ -330,6 +332,32 @@ fi
%changelog
+* Mon Jan 22 2024 Remi Collet <remi@remirepo.net> - 1.6.6-1
+- update to 1.6.6
+
+* Mon Nov 6 2023 Remi Collet <remi@remirepo.net> - 1.6.5-1
+- update to 1.6.5
+
+* Mon Oct 16 2023 Remi Collet <remi@remirepo.net> - 1.6.4-1
+- update to 1.6.4
+
+* Fri Sep 15 2023 Remi Collet <remi@remirepo.net> - 1.6.3-1
+- update to 1.6.3
+
+* Sun Jul 2 2023 Remi Collet <remi@remirepo.net> - 1.6.2-1
+- update to 1.6.2
+
+* Tue Jan 24 2023 Remi Collet <remi@remirepo.net> - 1.6.1-1
+- update to 1.6.1
+- use SPDX license id
+
+* Wed Aug 3 2022 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+
+* Mon Jun 13 2022 Remi Collet <remi@remirepo.net> - 1.6~rc-1
+- update to 1.6-rc
+- drop patch merged upstream
+
* Mon Mar 7 2022 Remi Collet <remi@remirepo.net> - 1.6~beta-1
- update to 1.6-beta
- raise dependency on PHP 7.3