summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-31 09:01:21 +0100
committerRemi Collet <remi@php.net>2021-12-31 09:01:21 +0100
commitf1746fa3fd05ee8f251c175f91544b8e887720c1 (patch)
tree75aefd4fba873ff5abb06afb1b26e060ec9acab7
parentf173c36b06b34b97140fba8c8671911147d34dd4 (diff)
update to 1.5.2
-rw-r--r--roundcubemail-bundled.php39
-rw-r--r--roundcubemail.spec7
2 files changed, 44 insertions, 2 deletions
diff --git a/roundcubemail-bundled.php b/roundcubemail-bundled.php
new file mode 100644
index 0000000..2acae7b
--- /dev/null
+++ b/roundcubemail-bundled.php
@@ -0,0 +1,39 @@
+<?php
+
+if (!isset($_SERVER['argv'][1])) {
+ echo "Missing arg\n";
+ exit(1);
+}
+$pkgs = file_get_contents($_SERVER['argv'][1]);
+if (!$pkgs) {
+ echo "can't read json file\n";
+ exit(2);
+}
+
+$pkgs = json_decode($pkgs, true);
+if (!is_array($pkgs)) {
+ echo "can't decode json file\n";
+ exit(3);
+}
+
+$lic = [];
+if (isset($pkgs['packages'])) {
+ foreach($pkgs['packages'] as $pkg) {
+ printf("Provides: bundled(php-%s) = %s\n", str_replace(['/', '_'], ['-', '-'], $pkg['name']), $pkg['version']);
+ $lic = array_merge($lic, $pkg['license']);
+ }
+} else if (isset($pkgs['dependencies'])) {
+ foreach($pkgs['dependencies'] as $pkg) {
+ $n = strtolower($pkg['name'] ?? $pkg['lib']);
+ $n = str_replace('.js', '', $n);
+ printf("Provides: bundled(js-%s) = %s\n", $n, $pkg['version']);
+ if (isset($pkg['license'])) {
+ $lic[] = $pkg['license'];
+ }
+ }
+} else {
+ echo "unkown content\n";
+ exit(4);
+}
+sort($lic);
+printf("\nLicense: %s\n", implode(' and ', array_unique($lic)));
diff --git a/roundcubemail.spec b/roundcubemail.spec
index f256789..4a2d453 100644
--- a/roundcubemail.spec
+++ b/roundcubemail.spec
@@ -18,14 +18,14 @@
%else
%global with_phpfpm 0
%endif
-%global upstream_version 1.5.1
+%global upstream_version 1.5.2
#global upstream_prever rc
%global roundcubedir %{_datadir}/roundcubemail
%global _logdir /var/log
Name: roundcubemail
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: Round Cube Webmail is a browser-based multilingual IMAP client
# Since 0.8 beta, the main code has been GPLv3+ with exceptions and
@@ -311,6 +311,9 @@ fi
%changelog
+* Thu Dec 30 2021 Remi Collet <remi@remirepo.net> - 1.5.2-1
+- update to 1.5.2
+
* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 1.5.1-2
- use all PHP bundled libraries