summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-05 09:25:51 +0200
committerRemi Collet <remi@remirepo.net>2021-07-05 09:25:51 +0200
commit0045ce0c248617780bbbc309b0d4ea8bdcfd7ff4 (patch)
tree0881a10d462b17b1d36ed913d3f8fa592c32f4d9
parent2eb9e398c3ebc84589de4c275c445b5ca224806e (diff)
update to 1.5-beta
drop dependency on pear/net_idna2 raise dependency on pear/net_smtp 1.9 raise dependency on masterminds/html5 2.7 add dependency on guzzlehttp/guzzle switch from mkopinsky/zxcvbn-php to bjeavons/zxcvbn-php
-rw-r--r--composer.json4
-rw-r--r--plugins/debug_logger/composer.json2
-rw-r--r--plugins/enigma/composer.json2
-rw-r--r--plugins/managesieve/composer.json2
-rw-r--r--plugins/vcard_attachments/composer.json2
-rw-r--r--roundcubemail.spec14
6 files changed, 13 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 96ec220..f6d3ae0 100644
--- a/composer.json
+++ b/composer.json
@@ -13,9 +13,9 @@
"pear/pear-core-minimal": "~1.10.1",
"pear/auth_sasl": "~1.1.0",
"pear/mail_mime": "~1.10.0",
- "pear/net_smtp": "~1.9.0",
+ "pear/net_smtp": "~1.10.0",
"pear/crypt_gpg": "~1.6.3",
- "pear/net_sieve": "~1.4.3",
+ "pear/net_sieve": "~1.4.5",
"roundcube/plugin-installer": "~0.2.0",
"masterminds/html5": "~2.7.0",
"endroid/qr-code": "~1.6.5",
diff --git a/plugins/debug_logger/composer.json b/plugins/debug_logger/composer.json
index 518a08b..9c48689 100644
--- a/plugins/debug_logger/composer.json
+++ b/plugins/debug_logger/composer.json
@@ -1,7 +1,7 @@
{
"name": "roundcube/debug_logger",
"type": "roundcube-plugin",
- "description": "Enhanced logging for debugging purposes. It is not recommened to be enabled on production systems without testing because of the somewhat increased memory, cpu and disk i/o overhead.",
+ "description": "Enhanced logging for debugging purposes. It is not recommended to be enabled on production systems without testing because of the somewhat increased memory, cpu and disk i/o overhead.",
"license": "GPL-3.0-or-later",
"version": "1.0",
"authors": [
diff --git a/plugins/enigma/composer.json b/plugins/enigma/composer.json
index 4a6090e..b19ad9b 100644
--- a/plugins/enigma/composer.json
+++ b/plugins/enigma/composer.json
@@ -3,7 +3,7 @@
"type": "roundcube-plugin",
"description": "Server-side PGP Encryption for Roundcube",
"license": "GPL-3.0-or-later",
- "version": "0.8",
+ "version": "0.9",
"authors": [
{
"name": "Aleksander Machniak",
diff --git a/plugins/managesieve/composer.json b/plugins/managesieve/composer.json
index 74c0db2..72a597c 100644
--- a/plugins/managesieve/composer.json
+++ b/plugins/managesieve/composer.json
@@ -3,7 +3,7 @@
"type": "roundcube-plugin",
"description": "Adds a possibility to manage Sieve scripts (incoming mail filters). It's clickable interface which operates on text scripts and communicates with server using managesieve protocol. Adds Filters tab in Settings.",
"license": "GPL-3.0-or-later",
- "version": "9.3",
+ "version": "9.4",
"authors": [
{
"name": "Aleksander Machniak",
diff --git a/plugins/vcard_attachments/composer.json b/plugins/vcard_attachments/composer.json
index 8cc8aa9..11fd431 100644
--- a/plugins/vcard_attachments/composer.json
+++ b/plugins/vcard_attachments/composer.json
@@ -3,7 +3,7 @@
"type": "roundcube-plugin",
"description": "Detects vCard attachments and allows to add them to address book. Also allows to attach vCards of your contacts to composed messages",
"license": "GPL-3.0-or-later",
- "version": "4.1",
+ "version": "4.2",
"authors": [
{
"name": "Thomas Bruederli",
diff --git a/roundcubemail.spec b/roundcubemail.spec
index 67a344e..6990a39 100644
--- a/roundcubemail.spec
+++ b/roundcubemail.spec
@@ -18,7 +18,7 @@
%global with_phpfpm 0
%endif
%global upstream_version 1.5
-%global upstream_prever beta
+%global upstream_prever rc
%global roundcubedir %{_datadir}/roundcubemail
%global _logdir /var/log
@@ -57,9 +57,9 @@ BuildRequires: php-cli
BuildRequires: php-pear(PEAR) >= 1.10.1
BuildRequires: php-pear(Auth_SASL) >= 1.1.0
BuildRequires: php-pear(Mail_Mime) >= 1.10.0
-BuildRequires: php-pear(Net_SMTP) >= 1.9.0
+BuildRequires: php-pear(Net_SMTP) >= 1.10.0
BuildRequires: php-pear(Crypt_GPG) >= 1.6.0
-BuildRequires: php-pear(Net_Sieve) >= 1.4.3
+BuildRequires: php-pear(Net_Sieve) >= 1.4.5
BuildRequires: php-pear(Net_LDAP2) >= 2.2.0
BuildRequires: php-composer(kolab/net_ldap3) >= 1.1.1
BuildRequires: php-composer(fedora/autoloader)
@@ -113,9 +113,9 @@ Requires: php-xml
# "pear/pear-core-minimal": "~1.10.1",
# "pear/auth_sasl": "~1.1.0",
# "pear/mail_mime": "~1.10.0",
-# "pear/net_smtp": "~1.9.0",
+# "pear/net_smtp": "~1.10.0",
# "pear/crypt_gpg": "~1.6.0",
-# "pear/net_sieve": "~1.4.3",
+# "pear/net_sieve": "~1.4.5",
# "roundcube/plugin-installer": "~0.1.6",
# "masterminds/html5": "~2.7.0",
# "endroid/qrcode": "~1.6.5"
@@ -287,7 +287,7 @@ popd
# clean up the buildroot
rm -r %{buildroot}%{roundcubedir}/{config,logs,temp}
-rm -r %{buildroot}%{roundcubedir}/{CHANGELOG,INSTALL,LICENSE,README.md,UPGRADING}
+rm -r %{buildroot}%{roundcubedir}/{CHANGELOG.md,INSTALL,LICENSE,README.md,UPGRADING}
rm %{buildroot}%{roundcubedir}/composer.json-dist
@@ -323,7 +323,7 @@ fi
# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
-%doc CHANGELOG INSTALL README.md UPGRADING README-rpm.txt
+%doc CHANGELOG.md INSTALL README.md UPGRADING README-rpm.txt
%doc composer.json-dist
%{roundcubedir}
%dir %{_sysconfdir}/%{name}