summaryrefslogtreecommitdiffstats
path: root/redis-deps-PIC.patch
diff options
context:
space:
mode:
Diffstat (limited to 'redis-deps-PIC.patch')
-rw-r--r--redis-deps-PIC.patch12
1 files changed, 6 insertions, 6 deletions
diff --git a/redis-deps-PIC.patch b/redis-deps-PIC.patch
index 4d9b958..d29cdfa 100644
--- a/redis-deps-PIC.patch
+++ b/redis-deps-PIC.patch
@@ -1,15 +1,15 @@
---- a/deps/Makefile
-+++ a/deps/Makefile
+--- a/deps/Makefile.pic 2014-09-04 20:14:53.780910375 +0200
++++ a/deps/Makefile 2014-09-04 20:15:49.278133046 +0200
@@ -58,7 +58,7 @@
LUA_CFLAGS= -D__C99FEATURES__=1
endif
-
+
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
+LUA_CFLAGS+= -O2 -Wall -fPIC -DLUA_ANSI $(CFLAGS)
LUA_LDFLAGS+= $(LDFLAGS)
-
- lua: .make-prerequisites
---- a/deps/linenoise/Makefile
+ # lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
+ # challenging to cross-compile lua (and redis). These defines make it easier
+--- a/deps/linenoise/Makefile
+++ a/deps/linenoise/Makefile
@@ -2,7 +2,7 @@ STD=
WARN= -Wall