summaryrefslogtreecommitdiffstats
path: root/redis-deps-PIC.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-07-28 09:01:38 +0200
committerRemi Collet <fedora@famillecollet.com>2013-07-28 09:01:38 +0200
commit8bf04f284c664c0974c467670c0bdb1c623799e5 (patch)
tree7eeb2efd6699f73ba66e2f64ac5fe4c8bb977101 /redis-deps-PIC.patch
parent1a163cdf45ba6cfcabca5d5b18e0fde5f28e9f09 (diff)
redis: sync with rawhide + update to 2.6.14
Diffstat (limited to 'redis-deps-PIC.patch')
-rw-r--r--redis-deps-PIC.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/redis-deps-PIC.patch b/redis-deps-PIC.patch
new file mode 100644
index 0000000..944fa35
--- /dev/null
+++ b/redis-deps-PIC.patch
@@ -0,0 +1,23 @@
+--- a/deps/Makefile
++++ a/deps/Makefile
+@@ -58,7 +58,7 @@ ifeq ($(uname_S),SunOS)
+ LUA_CFLAGS= -D__C99FEATURES__=1
+ endif
+
+-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
++LUA_CFLAGS+= -O2 -Wall -fPIC -DLUA_ANSI $(CFLAGS)
+ LUA_LDFLAGS+= $(LDFLAGS)
+
+ lua: .make-prerequisites
+--- a/deps/linenoise/Makefile
++++ a/deps/linenoise/Makefile
+@@ -2,7 +2,7 @@ STD=
+ WARN= -Wall
+ OPT= -Os
+
+-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
++R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
+ R_LDFLAGS= $(LDFLAGS)
+ DEBUG= -g
+
+