summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-12-05 11:10:47 +0100
committerRemi Collet <fedora@famillecollet.com>2014-12-05 11:10:47 +0100
commit2e64c95833b0d06d7b98c31978e0c52f08c183f9 (patch)
treedb8db4eb0cda9c976b9863ab84c518c2df017c27
parent3d26d517415c68e3865b1b3c8e0a9a39f35c38bf (diff)
redis: EL-5 rebuild with upstream patch
-rw-r--r--redis-2.8.18-el5.patch48
-rw-r--r--redis.spec9
2 files changed, 32 insertions, 25 deletions
diff --git a/redis-2.8.18-el5.patch b/redis-2.8.18-el5.patch
index 5de5436..ac43df1 100644
--- a/redis-2.8.18-el5.patch
+++ b/redis-2.8.18-el5.patch
@@ -1,25 +1,31 @@
-diff -up redis-2.8.18/deps/lua/src/lua_cmsgpack.c.el5 redis-2.8.18/deps/lua/src/lua_cmsgpack.c
---- redis-2.8.18/deps/lua/src/lua_cmsgpack.c.el5 2014-12-05 06:42:14.000000000 +0100
-+++ redis-2.8.18/deps/lua/src/lua_cmsgpack.c 2014-12-05 06:59:31.000000000 +0100
-@@ -18,7 +18,7 @@
+From ff25d1896d3befe184aa1adebf5d5e961f5d4b15 Mon Sep 17 00:00:00 2001
+From: antirez <antirez@gmail.com>
+Date: Fri, 5 Dec 2014 10:51:09 +0100
+Subject: [PATCH] Simplify lua_cmsgpack macro and fix build on old Linux
+ distros.
+
+Thanks to @badboy for the help in checking the build after the fix.
+---
+ deps/lua/src/lua_cmsgpack.c | 8 +-------
+ 1 file changed, 1 insertion(+), 7 deletions(-)
+
+diff --git a/deps/lua/src/lua_cmsgpack.c b/deps/lua/src/lua_cmsgpack.c
+index 6aa04e2..4ccf07f 100644
+--- a/deps/lua/src/lua_cmsgpack.c
++++ b/deps/lua/src/lua_cmsgpack.c
+@@ -18,14 +18,8 @@
#define LUACMSGPACK_MAX_NESTING 16 /* Max tables nesting. */
#endif
-#if (_XOPEN_SOURCE >= 600 || _ISOC99_SOURCE || _POSIX_C_SOURCE >= 200112L)
-+#if 0
- #define IS_FINITE(x) isfinite(x)
- #else
- #define IS_FINITE(x) ((x) == (x) && (x) + 1 > (x))
-diff -up redis-2.8.18/src/config.h.el5 redis-2.8.18/src/config.h
---- redis-2.8.18/src/config.h.el5 2014-12-05 06:39:29.000000000 +0100
-+++ redis-2.8.18/src/config.h 2014-12-05 07:09:53.000000000 +0100
-@@ -191,7 +191,7 @@ void setproctitle(const char *fmt, ...);
- #if defined(__clang__)
- #define HAVE_ATOMIC
- #endif
--#if (defined(__GLIBC__) && defined(__GLIBC_PREREQ))
-+#if (defined(__GLIBC__) && defined(__GLIBC_PREREQ)) && defined(__x86_64__)
- #if (GNUC_VERSION >= 40100 && __GLIBC_PREREQ(2, 6))
- #define HAVE_ATOMIC
- #endif
-diff -up redis-2.8.18/src/rdb.c.el5 redis-2.8.18/src/rdb.c
+- #define IS_FINITE(x) isfinite(x)
+-#else
+- #define IS_FINITE(x) ((x) == (x) && (x) + 1 > (x))
+-#endif
+-
+ /* Check if float or double can be an integer without loss of precision */
+-#define IS_INT_TYPE_EQUIVALENT(x, T) (IS_FINITE(x) && (T)(x) == (x))
++#define IS_INT_TYPE_EQUIVALENT(x, T) (!isinf(x) && (T)(x) == (x))
+
+ #define IS_INT64_EQUIVALENT(x) IS_INT_TYPE_EQUIVALENT(x, int64_t)
+ #define IS_INT_EQUIVALENT(x) IS_INT_TYPE_EQUIVALENT(x, int)
diff --git a/redis.spec b/redis.spec
index daacda5..37ad73f 100644
--- a/redis.spec
+++ b/redis.spec
@@ -11,7 +11,7 @@
Name: redis
Version: 2.8.18
-Release: 1%{?dist}
+Release: 1%{?dist}.1
Summary: A persistent key-value database
Group: Applications/Databases
@@ -72,9 +72,7 @@ Documentation: http://redis.io/documentation
%patch1 -p1 -b .pic
%patch2 -p1 -b .jem
-%if 0%{?rhel} == 5
-%patch9 -p1 -b .el5
-%endif
+%patch9 -p1 -b .upstream
%build
@@ -218,6 +216,9 @@ fi
%changelog
+* Thu Dec 4 2014 Remi Collet <remi@fedoraproject.org> - 2.8.18-1.1
+- EL-5 rebuild with upstream patch
+
* Thu Dec 4 2014 Remi Collet <remi@fedoraproject.org> - 2.8.18-1
- Redis 2.8.18 - Release date: 4 Dec 2014
upgrade urgency: LOW for both Redis and Sentinel.