summaryrefslogtreecommitdiffstats
path: root/pie.spec
diff options
context:
space:
mode:
Diffstat (limited to 'pie.spec')
-rw-r--r--pie.spec14
1 files changed, 7 insertions, 7 deletions
diff --git a/pie.spec b/pie.spec
index d38f7f4..40a6811 100644
--- a/pie.spec
+++ b/pie.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-# remirepo:2
+# remirepo:3
# For compatibility with SCL
%undefine __brp_mangle_shebangs
@@ -34,9 +34,10 @@ Summary: PHP Installer for Extensions
# SPDX: pie is BSD-3-Clause, all dependencies are MIT
License: BSD-3-Clause and MIT
URL: https://github.com/php/pie
+# tarball generated by makesrc.sh
Source0: %{gh_project}-%{upstream_version}%{?upstream_prever}-%{gh_short}.tgz
Source1: %{name}-bash-completion
-# Get a git snapshot with dependencies
+# Create a git snapshot with dependencies
Source9: makesrc.sh
# Fix autoloader path
@@ -53,7 +54,7 @@ BuildRequires: pkgconfig(bash-completion)
# From composer.json, "require": {
# "php": "8.1.*||8.2.*||8.3.*||8.4.*",
# "ext-zip": "*",
-Requires: php(language) >= 8.1
+Requires: php(language) >= 8.1
Requires: php-cli
Requires: php-zip
# System certificates
@@ -153,8 +154,7 @@ php -r '
foreach($res as $lic => $lib) {
sort($lib);
printf("# License %s\n%s\n", $lic, implode("\n", $lib));
- }
-'
+ }'
%build
@@ -162,10 +162,10 @@ php -r '
%install
-: Profile scripts
+: Bash auto-completion
install -Dpm 644 %{SOURCE1} %{buildroot}%{bashcompdir}/%{name}
-: Library
+: Sources and dependencies
mkdir -p %{buildroot}%{_datadir}/%{name}
cp -pr src %{buildroot}%{_datadir}/%{name}/src
cp -pr vendor %{buildroot}%{_datadir}/%{name}/vendor