summaryrefslogtreecommitdiffstats
path: root/makesrc.sh
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-10-30 11:53:32 +0100
committerRemi Collet <remi@php.net>2024-10-30 11:53:32 +0100
commit19c570a6c92997ee6e04e620f683707cea57cd22 (patch)
treed346c3d6b42b92eb3bd4c2ccaea4d8051daa62ec /makesrc.sh
parent3a9b6d7bac8ef00a639559ee5e63f3853275de7d (diff)
refresh dependencies
add patches from composer to skip XDG and drop bundled cacert.rpm
Diffstat (limited to 'makesrc.sh')
-rwxr-xr-xmakesrc.sh2
1 files changed, 1 insertions, 1 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 209f17e..ea2a516 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -9,7 +9,7 @@ PREVER=$(sed -n '/^%global upstream_prever/{s/.* //;p}' $NAME.spec)
COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
SHORT=${COMMIT:0:7}
-if [ -f $NAME-$VERSION$PREVER-$SHORT.tgz ]; then
+if [ -f $NAME-$VERSION$PREVER-$SHORT.tgz -a "$1" != "-f" ]; then
echo skip $NAME-$VERSION$PREVER-$SHORT.tgz already here
else
echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION$PREVER\n"