summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--phpunit7-rpm.patch17
-rw-r--r--phpunit7.spec9
2 files changed, 13 insertions, 13 deletions
diff --git a/phpunit7-rpm.patch b/phpunit7-rpm.patch
index ac1ba36..bb75e19 100644
--- a/phpunit7-rpm.patch
+++ b/phpunit7-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2018-10-05 07:24:04.878465790 +0200
-+++ ./phpunit 2018-10-05 07:28:13.403045771 +0200
+--- ./phpunit.rpm 2019-01-15 09:19:08.000000000 +0100
++++ ./phpunit 2019-01-15 11:49:08.859885786 +0100
@@ -27,25 +27,12 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
@@ -44,8 +44,8 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
+}
diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
---- ./src/Util/Configuration.php.rpm 2018-10-05 06:05:24.000000000 +0200
-+++ ./src/Util/Configuration.php 2018-10-05 07:24:04.879465796 +0200
+--- ./src/Util/Configuration.php.rpm 2019-01-15 09:19:08.000000000 +0100
++++ ./src/Util/Configuration.php 2019-01-15 11:49:08.859885786 +0100
@@ -1025,7 +1025,7 @@ final class Configuration
private function validateConfigurationAgainstSchema(): void
{
@@ -56,9 +56,9 @@ diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
if (\defined('__PHPUNIT_PHAR_ROOT__')) {
$xsdFilename = __PHPUNIT_PHAR_ROOT__ . '/phpunit.xsd';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2018-10-05 06:05:24.000000000 +0200
-+++ ./tests/bootstrap.php 2018-10-05 07:24:04.878465790 +0200
-@@ -14,7 +14,12 @@ if (!\defined('TEST_FILES_PATH')) {
+--- ./tests/bootstrap.php.rpm 2019-01-15 11:49:08.859885786 +0100
++++ ./tests/bootstrap.php 2019-01-15 11:50:12.567276300 +0100
+@@ -14,4 +14,9 @@ if (!\defined('TEST_FILES_PATH')) {
\ini_set('precision', 14);
\ini_set('serialize_precision', 14);
@@ -69,6 +69,3 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
+require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
+require_once '@PATH@/Framework/Assert/Functions.php';
+require_once __DIR__ . '/autoload.php';
-
- // TODO: Figure out why these are required (the classes should be autoloaded instead)
- require_once TEST_FILES_PATH . 'BeforeAndAfterTest.php';
diff --git a/phpunit7.spec b/phpunit7.spec
index bb344b4..9670771 100644
--- a/phpunit7.spec
+++ b/phpunit7.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for phpunit7
#
-# Copyright (c) 2010-2018 Remi Collet
+# Copyright (c) 2010-2019 Remi Collet
#
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c23d78776ad415d5506e0679723cb461d71f488f
+%global gh_commit 7c89093bd00f7d5ddf0ab81dee04f801416b4944
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -24,7 +24,7 @@
%global php_home %{_datadir}/php
%global ver_major 7
%global ver_minor 5
-%global ver_patch 1
+%global ver_patch 2
%global specrel 1
Name: %{pk_project}%{ver_major}
@@ -267,6 +267,9 @@ exit $ret
%changelog
+* Tue Jan 15 2019 Remi Collet <remi@remirepo.net> - 7.5.2-1
+- update to 7.5.2
+
* Wed Dec 12 2018 Remi Collet <remi@remirepo.net> - 7.5.1-1
- update to 7.5.1