summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--phpunit7-rpm.patch37
-rw-r--r--phpunit7.spec22
3 files changed, 35 insertions, 28 deletions
diff --git a/composer.json b/composer.json
index f9f33a4..76336de 100644
--- a/composer.json
+++ b/composer.json
@@ -42,7 +42,7 @@
"sebastian/exporter": "^3.1",
"sebastian/global-state": "^2.0",
"sebastian/object-enumerator": "^3.0.3",
- "sebastian/resource-operations": "^1.0",
+ "sebastian/resource-operations": "^2.0",
"sebastian/version": "^2.0.1"
},
"require-dev": {
@@ -84,7 +84,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "7.3-dev"
+ "dev-master": "7.4-dev"
}
}
}
diff --git a/phpunit7-rpm.patch b/phpunit7-rpm.patch
index 15cf866..ac1ba36 100644
--- a/phpunit7-rpm.patch
+++ b/phpunit7-rpm.patch
@@ -1,7 +1,7 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2018-04-18 15:41:53.000000000 +0200
-+++ ./phpunit 2018-04-18 17:47:22.114947265 +0200
-@@ -27,27 +27,18 @@ if (!ini_get('date.timezone')) {
+--- ./phpunit.rpm 2018-10-05 07:24:04.878465790 +0200
++++ ./phpunit 2018-10-05 07:28:13.403045771 +0200
+@@ -27,25 +27,12 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
@@ -32,6 +32,9 @@ diff -up ./phpunit.rpm ./phpunit
+ define ('PHPUNIT_COMPOSER_INSTALL', '/usr/share/php/PHPUnit7/autoload.php');
}
+ $options = getopt('', array('prepend:'));
+@@ -58,4 +45,8 @@ unset($options);
+
require PHPUNIT_COMPOSER_INSTALL;
-PHPUnit\TextUI\Command::main();
@@ -40,9 +43,21 @@ diff -up ./phpunit.rpm ./phpunit
+} else {
+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
+}
+diff -up ./src/Util/Configuration.php.rpm ./src/Util/Configuration.php
+--- ./src/Util/Configuration.php.rpm 2018-10-05 06:05:24.000000000 +0200
++++ ./src/Util/Configuration.php 2018-10-05 07:24:04.879465796 +0200
+@@ -1025,7 +1025,7 @@ final class Configuration
+ private function validateConfigurationAgainstSchema(): void
+ {
+ $original = \libxml_use_internal_errors(true);
+- $xsdFilename = __DIR__ . '/../../phpunit.xsd';
++ $xsdFilename = __DIR__ . '/../phpunit.xsd';
+
+ if (\defined('__PHPUNIT_PHAR_ROOT__')) {
+ $xsdFilename = __PHPUNIT_PHAR_ROOT__ . '/phpunit.xsd';
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2018-04-18 17:47:22.114947265 +0200
-+++ ./tests/bootstrap.php 2018-04-18 17:49:00.630467371 +0200
+--- ./tests/bootstrap.php.rpm 2018-10-05 06:05:24.000000000 +0200
++++ ./tests/bootstrap.php 2018-10-05 07:24:04.878465790 +0200
@@ -14,7 +14,12 @@ if (!\defined('TEST_FILES_PATH')) {
\ini_set('precision', 14);
\ini_set('serialize_precision', 14);
@@ -57,15 +72,3 @@ diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
// TODO: Figure out why these are required (the classes should be autoloaded instead)
require_once TEST_FILES_PATH . 'BeforeAndAfterTest.php';
-diff -up src/Util/Configuration.php.rpm src/Util/Configuration.php
---- src/Util/Configuration.php.rpm 2018-06-01 08:58:20.650603791 +0200
-+++ src/Util/Configuration.php 2018-06-01 08:58:28.559655848 +0200
-@@ -979,7 +979,7 @@ final class Configuration
- private function validateConfigurationAgainstSchema(): void
- {
- $original = \libxml_use_internal_errors(true);
-- $xsdFilename = __DIR__ . '/../../phpunit.xsd';
-+ $xsdFilename = __DIR__ . '/../phpunit.xsd';
-
- if (\defined('__PHPUNIT_PHAR_ROOT__')) {
- $xsdFilename = __PHPUNIT_PHAR_ROOT__ . '/phpunit.xsd';
diff --git a/phpunit7.spec b/phpunit7.spec
index 26b976e..0c3218f 100644
--- a/phpunit7.spec
+++ b/phpunit7.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 7b331efabbb628c518c408fdfcaf571156775de2
+%global gh_commit f3837fa1e07758057ae06e8ddec6d06ba183f126
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -23,8 +23,8 @@
%global ns_vendor PHPUnit7
%global php_home %{_datadir}/php
%global ver_major 7
-%global ver_minor 3
-%global ver_patch 5
+%global ver_minor 4
+%global ver_patch 0
%global specrel 1
Name: %{pk_project}%{ver_major}
@@ -58,7 +58,7 @@ BuildRequires: (php-composer(sebastian/environment) >= 3.1 with php-co
BuildRequires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
BuildRequires: (php-composer(sebastian/global-state) >= 2.0 with php-composer(sebastian/global-state) < 3)
BuildRequires: (php-composer(sebastian/object-enumerator) >= 3.0.3 with php-composer(sebastian/object-enumerator) < 4)
-BuildRequires: (php-composer(sebastian/resource-operations) >= 1.0 with php-composer(sebastian/resource-operations) < 2)
+BuildRequires: (php-composer(sebastian/resource-operations) >= 2.0 with php-composer(sebastian/resource-operations) < 3)
BuildRequires: (php-composer(sebastian/version) >= 2.0.1 with php-composer(sebastian/version) < 3)
BuildRequires: (php-composer(phpunit/php-invoker) >= 2.0 with php-composer(phpunit/php-invoker) < 3)
# remirepo:20
@@ -78,7 +78,7 @@ BuildRequires: php-sebastian-environment3 >= 3.1
BuildRequires: php-sebastian-exporter3 >= 3.1
BuildRequires: php-sebastian-global-state2
BuildRequires: php-sebastian-object-enumerator3 >= 3.0.3
-BuildRequires: php-sebastian-resource-operations
+BuildRequires: php-sebastian-resource-operations2
BuildRequires: php-phpunit-Version >= 2.0.1
BuildRequires: php-phpunit-php-invoker2
%endif
@@ -113,7 +113,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "sebastian/exporter": "^3.1",
# "sebastian/global-state": "^2.0",
# "sebastian/object-enumerator": "^3.0.3",
-# "sebastian/resource-operations": "^1.0",
+# "sebastian/resource-operations": "^2.0",
# "sebastian/version": "^2.0.1",
Requires: php(language) >= 7.1
Requires: php-cli
@@ -139,7 +139,7 @@ Requires: (php-composer(sebastian/environment) >= 3.1 with php-co
Requires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
Requires: (php-composer(sebastian/global-state) >= 2.0 with php-composer(sebastian/global-state) < 3)
Requires: (php-composer(sebastian/object-enumerator) >= 3.0.3 with php-composer(sebastian/object-enumerator) < 4)
-Requires: (php-composer(sebastian/resource-operations) >= 1.0 with php-composer(sebastian/resource-operations) < 2)
+Requires: (php-composer(sebastian/resource-operations) >= 2.0 with php-composer(sebastian/resource-operations) < 3)
Requires: (php-composer(sebastian/version) >= 2.0.1 with php-composer(sebastian/version) < 3)
# From composer.json, "suggest": {
# "phpunit/php-invoker": "^2.0",
@@ -162,7 +162,7 @@ Requires: php-sebastian-environment3 >= 3.1
Requires: php-sebastian-exporter3 >= 3.1
Requires: php-sebastian-global-state2
Requires: php-sebastian-object-enumerator3 >= 3.0.3
-Requires: php-sebastian-resource-operations
+Requires: php-sebastian-resource-operations2
Requires: php-phpunit-Version >= 2.0.1
Requires: php-phpunit-php-invoker2
%endif
@@ -215,7 +215,7 @@ cat << 'EOF' | tee -a src/autoload.php
'%{php_home}/SebastianBergmann/Exporter3/autoload.php',
'%{php_home}/SebastianBergmann/GlobalState2/autoload.php',
'%{php_home}/SebastianBergmann/ObjectEnumerator3/autoload.php',
- '%{php_home}/SebastianBergmann/ResourceOperations/autoload.php',
+ '%{php_home}/SebastianBergmann/ResourceOperations2/autoload.php',
'%{php_home}/SebastianBergmann/Version/autoload.php',
[
'%{php_home}/Doctrine/Instantiator11/autoload.php',
@@ -273,6 +273,10 @@ exit $ret
%changelog
+* Fri Oct 5 2018 Remi Collet <remi@remirepo.net> - 7.4.0-1
+- update to 7.4.0
+- raise dependency on sebastian/resource-operations 2.0
+
* Sun Sep 9 2018 Remi Collet <remi@remirepo.net> - 7.3.5-1
- update to 7.3.5