summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--3355.patch24
-rw-r--r--phpunit7.spec12
2 files changed, 7 insertions, 29 deletions
diff --git a/3355.patch b/3355.patch
deleted file mode 100644
index 9cfaa05..0000000
--- a/3355.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Adapted for 7.4.1 from
-
-From 03e86defca1096cfbbf9962c1151773ac8767fcb Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 18 Oct 2018 14:58:51 +0200
-Subject: [PATCH] Fix #3354
-
----
- src/TextUI/TestRunner.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/TextUI/TestRunner.php b/src/TextUI/TestRunner.php
-index 00c2fcf860..bc167dd14e 100644
---- a/src/TextUI/TestRunner.php
-+++ b/src/TextUI/TestRunner.php
-@@ -158,7 +158,7 @@ class TestRunner extends BaseTestRunner
-
- $this->handleConfiguration($arguments);
-
-- if ($arguments['columns'] < 16) {
-+ if (\is_int($arguments['columns']) && $arguments['columns'] < 16) {
- $arguments['columns'] = 16;
- $tooFewColumnsRequested = true;
- }
diff --git a/phpunit7.spec b/phpunit7.spec
index b1ec880..600afaa 100644
--- a/phpunit7.spec
+++ b/phpunit7.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit c5a120ade60992bd671a912188ee9ee9f8083bbd
+%global gh_commit c151651fb6ed264038d486ea262e243af72e5e64
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -24,8 +24,8 @@
%global php_home %{_datadir}/php
%global ver_major 7
%global ver_minor 4
-%global ver_patch 1
-%global specrel 2
+%global ver_patch 3
+%global specrel 1
Name: %{pk_project}%{ver_major}
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
@@ -38,7 +38,6 @@ Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commi
# Fix command for autoload
Patch0: %{name}-rpm.patch
-Patch1: https://patch-diff.githubusercontent.com/raw/sebastianbergmann/phpunit/pull/3355.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.1
@@ -194,7 +193,6 @@ It is an instance of the xUnit architecture for unit testing frameworks.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0 -b .rpm
-%patch1 -p1
%build
@@ -278,6 +276,10 @@ exit $ret
%changelog
+* Tue Oct 23 2018 Remi Collet <remi@remirepo.net> - 7.4.3-1
+- update to 7.4.3
+- drop patch merged upstream
+
* Thu Oct 18 2018 Remi Collet <remi@remirepo.net> - 7.4.1-2
- add patch for https://github.com/sebastianbergmann/phpunit/issues/3354
from https://github.com/sebastianbergmann/phpunit/pull/3355