summaryrefslogtreecommitdiffstats
path: root/phpunit7.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-07-16 07:07:16 +0200
committerRemi Collet <remi@remirepo.net>2018-07-16 07:07:16 +0200
commit2f8a8af588c94932e381d654caa782f5c3d1a5bd (patch)
treef450f084851b64f110584585a628f247df1a91e8 /phpunit7.spec
parent91e8cf9885c10ade4f28f524fd481d1fc4531853 (diff)
update to 7.2.7
allow phar-io/version 2.0
Diffstat (limited to 'phpunit7.spec')
-rw-r--r--phpunit7.spec15
1 files changed, 10 insertions, 5 deletions
diff --git a/phpunit7.spec b/phpunit7.spec
index 212e42b..a8b70bf 100644
--- a/phpunit7.spec
+++ b/phpunit7.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 400a3836ee549ae6f665323ac3f21e27eac7155f
+%global gh_commit 8e878aff7917ef66e702e03d1359b16eee254e2c
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -24,7 +24,7 @@
%global php_home %{_datadir}/php
%global ver_major 7
%global ver_minor 2
-%global ver_patch 6
+%global ver_patch 7
%global specrel 1
Name: %{pk_project}%{ver_major}
@@ -46,7 +46,7 @@ BuildRequires: php(language) >= 7.1
BuildRequires: (php-composer(doctrine/instantiator) >= 1.1 with php-composer(doctrine/instantiator) < 2)
BuildRequires: (php-composer(myclabs/deep-copy) >= 1.7 with php-composer(myclabs/deep-copy) < 2)
BuildRequires: (php-composer(phar-io/manifest) >= 1.0.1 with php-composer(phar-io/manifest) < 2)
-BuildRequires: (php-composer(phar-io/version) >= 1.0 with php-composer(phar-io/version) < 2)
+BuildRequires: (php-composer(phar-io/version) >= 1.0 with php-composer(phar-io/version) < 3)
BuildRequires: (php-composer(phpspec/prophecy) >= 1.7 with php-composer(phpspec/prophecy) < 2)
BuildRequires: (php-composer(phpunit/php-code-coverage) >= 6.0.7 with php-composer(phpunit/php-code-coverage) < 7)
BuildRequires: (php-composer(phpunit/php-file-iterator) >= 2.0.1 with php-composer(phpunit/php-file-iterator) < 3)
@@ -99,6 +99,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "ext-xml": "*",
# "doctrine/instantiator": "^1.1",
# "myclabs/deep-copy": "^1.7",
+# ignore version range, test suite passes with manifest and version 1.0.1
# "phar-io/manifest": "^1.0.1",
# "phar-io/version": "^1.0",
# "phpspec/prophecy": "^1.7",
@@ -126,7 +127,7 @@ Requires: php-xml
Requires: (php-composer(doctrine/instantiator) >= 1.1 with php-composer(doctrine/instantiator) < 2)
Requires: (php-composer(myclabs/deep-copy) >= 1.7 with php-composer(myclabs/deep-copy) < 2)
Requires: (php-composer(phar-io/manifest) >= 1.0.1 with php-composer(phar-io/manifest) < 2)
-Requires: (php-composer(phar-io/version) >= 1.0 with php-composer(phar-io/version) < 2)
+Requires: (php-composer(phar-io/version) >= 1.0 with php-composer(phar-io/version) < 3)
Requires: (php-composer(phpspec/prophecy) >= 1.7 with php-composer(phpspec/prophecy) < 2)
Requires: (php-composer(phpunit/php-code-coverage) >= 6.0.7 with php-composer(phpunit/php-code-coverage) < 7)
Requires: (php-composer(phpunit/php-file-iterator) >= 2.0.1 with php-composer(phpunit/php-file-iterator) < 3)
@@ -254,7 +255,7 @@ sed -e 's:@PATH@:%{buildroot}%{php_home}/%{ns_vendor}:' -i tests/bootstrap.php
sed -e 's:%{php_home}/%{ns_vendor}:%{buildroot}%{php_home}/%{ns_vendor}:' -i phpunit
ret=0
-for cmd in php php71 php72; do
+for cmd in php php71 php72 php73; do
if which $cmd; then
$cmd ./phpunit $OPT --verbose || ret=1
fi
@@ -272,6 +273,10 @@ exit $ret
%changelog
+* Mon Jul 16 2018 Remi Collet <remi@remirepo.net> - 7.2.7-1
+- update to 7.2.7
+- allow phar-io/version 2.0
+
* Thu Jun 21 2018 Remi Collet <remi@remirepo.net> - 7.2.6-1
- update to 7.2.6