summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-18 18:21:52 +0200
committerRemi Collet <remi@remirepo.net>2018-04-18 18:21:52 +0200
commit7c217e94e7d4713812e00fc0b26c2e5db1255dc0 (patch)
treef381a65598dc09fe4a97d2e78e46a195816cb7a4
parent19397527655a3032bebc2e0eecae5185a7b4b97f (diff)
update to 7.1.4
allow sebastian/comparator 3.0
-rw-r--r--composer.json2
-rw-r--r--phpunit7-rpm.patch18
-rw-r--r--phpunit7.spec25
3 files changed, 27 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 712aca9..b13338c 100644
--- a/composer.json
+++ b/composer.json
@@ -36,7 +36,7 @@
"phpunit/php-text-template": "^1.2.1",
"phpunit/php-timer": "^2.0",
"phpunit/phpunit-mock-objects": "^6.1.1",
- "sebastian/comparator": "^2.1",
+ "sebastian/comparator": "^2.1 || ^3.0",
"sebastian/diff": "^3.0",
"sebastian/environment": "^3.1",
"sebastian/exporter": "^3.1",
diff --git a/phpunit7-rpm.patch b/phpunit7-rpm.patch
index db9bdfe..48385bc 100644
--- a/phpunit7-rpm.patch
+++ b/phpunit7-rpm.patch
@@ -1,6 +1,6 @@
diff -up ./phpunit.rpm ./phpunit
---- ./phpunit.rpm 2018-02-02 06:04:08.000000000 +0100
-+++ ./phpunit 2018-02-02 10:25:26.281085072 +0100
+--- ./phpunit.rpm 2018-04-18 15:41:53.000000000 +0200
++++ ./phpunit 2018-04-18 17:47:22.114947265 +0200
@@ -27,27 +27,18 @@ if (!ini_get('date.timezone')) {
ini_set('date.timezone', 'UTC');
}
@@ -41,17 +41,19 @@ diff -up ./phpunit.rpm ./phpunit
+ PHPUnit\TextUI\Command::main(); // PHPUnit v6 or newer
+}
diff -up ./tests/bootstrap.php.rpm ./tests/bootstrap.php
---- ./tests/bootstrap.php.rpm 2018-02-02 06:04:08.000000000 +0100
-+++ ./tests/bootstrap.php 2018-02-02 10:24:37.643848378 +0100
-@@ -6,7 +6,10 @@ if (!defined('TEST_FILES_PATH')) {
- ini_set('precision', 14);
- ini_set('serialize_precision', 14);
+--- ./tests/bootstrap.php.rpm 2018-04-18 17:47:22.114947265 +0200
++++ ./tests/bootstrap.php 2018-04-18 17:49:00.630467371 +0200
+@@ -14,7 +14,12 @@ if (!\defined('TEST_FILES_PATH')) {
+ \ini_set('precision', 14);
+ \ini_set('serialize_precision', 14);
-require_once __DIR__ . '/../vendor/autoload.php';
+require_once '@PATH@/autoload.php';
++require_once __DIR__ . '/_files/CoverageNamespacedFunctionTest.php';
+require_once __DIR__ . '/_files/CoveredFunction.php';
++require_once __DIR__ . '/_files/NamespaceCoveredFunction.php';
+require_once '@PATH@/Framework/Assert/Functions.php';
+require_once __DIR__ . '/autoload.php';
- // TODO: Figure out why (some of) these are required (the classes should be autoloaded instead)
+ // TODO: Figure out why these are required (the classes should be autoloaded instead)
require_once TEST_FILES_PATH . 'BeforeAndAfterTest.php';
diff --git a/phpunit7.spec b/phpunit7.spec
index 9df76d0..6c6a136 100644
--- a/phpunit7.spec
+++ b/phpunit7.spec
@@ -11,7 +11,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit a7834993ddbf4b0ed2c3b2dc1f3b1d093ef910a9
+%global gh_commit 6d51299e307dc510149e0b7cd1931dd11770e1cb
#global gh_date 20150927
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_vendor sebastianbergmann
@@ -24,7 +24,7 @@
%global php_home %{_datadir}/php
%global ver_major 7
%global ver_minor 1
-%global ver_patch 3
+%global ver_patch 4
%global specrel 1
Name: %{pk_project}%{ver_major}
@@ -42,7 +42,7 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.1
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(myclabs/deep-copy) >= 1.6.1 with php-composer(myclabs/deep-copy) < 2)
BuildRequires: (php-composer(phar-io/manifest) >= 1.0.1 with php-composer(phar-io/manifest) < 2)
BuildRequires: (php-composer(phar-io/version) >= 1.0 with php-composer(phar-io/version) < 2)
@@ -52,7 +52,7 @@ BuildRequires: (php-composer(phpunit/php-file-iterator) >= 1.4.3 with php-co
BuildRequires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
BuildRequires: (php-composer(phpunit/php-timer) >= 2.0 with php-composer(phpunit/php-timer) < 3)
BuildRequires: (php-composer(phpunit/phpunit-mock-objects) >= 6.1.1 with php-composer(phpunit/phpunit-mock-objects) < 7)
-BuildRequires: (php-composer(sebastian/comparator) >= 2.1 with php-composer(sebastian/comparator) < 3)
+BuildRequires: (php-composer(sebastian/comparator) >= 2.1 with php-composer(sebastian/comparator) < 4)
BuildRequires: (php-composer(sebastian/diff) >= 3.0 with php-composer(sebastian/diff) < 4)
BuildRequires: (php-composer(sebastian/environment) >= 3.1 with php-composer(sebastian/environment) < 4)
BuildRequires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
@@ -106,7 +106,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# "phpunit/php-text-template": "^1.2.1",
# "phpunit/php-timer": "^2.0",
# "phpunit/phpunit-mock-objects": "^6.1.1",
-# "sebastian/comparator": "^2.1",
+# "sebastian/comparator": "^2.1 || ^3.0",
# "sebastian/diff": "^3.0",
# "sebastian/environment": "^3.1",
# "sebastian/exporter": "^3.1",
@@ -122,7 +122,7 @@ Requires: php-libxml
Requires: php-mbstring
Requires: php-xml
# remirepo:1
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(myclabs/deep-copy) >= 1.6.1 with php-composer(myclabs/deep-copy) < 2)
Requires: (php-composer(phar-io/manifest) >= 1.0.1 with php-composer(phar-io/manifest) < 2)
Requires: (php-composer(phar-io/version) >= 1.0 with php-composer(phar-io/version) < 2)
@@ -132,7 +132,7 @@ Requires: (php-composer(phpunit/php-file-iterator) >= 1.4.3 with php-co
Requires: (php-composer(phpunit/php-text-template) >= 1.2.1 with php-composer(phpunit/php-text-template) < 2)
Requires: (php-composer(phpunit/php-timer) >= 2.0 with php-composer(phpunit/php-timer) < 3)
Requires: (php-composer(phpunit/phpunit-mock-objects) >= 6.1.1 with php-composer(phpunit/phpunit-mock-objects) < 7)
-Requires: (php-composer(sebastian/comparator) >= 2.1 with php-composer(sebastian/comparator) < 3)
+Requires: (php-composer(sebastian/comparator) >= 2.1 with php-composer(sebastian/comparator) < 4)
Requires: (php-composer(sebastian/diff) >= 3.0 with php-composer(sebastian/diff) < 4)
Requires: (php-composer(sebastian/environment) >= 3.1 with php-composer(sebastian/environment) < 4)
Requires: (php-composer(sebastian/exporter) >= 3.1 with php-composer(sebastian/exporter) < 4)
@@ -175,7 +175,7 @@ Requires: php-pcre
Requires: php-phar
Requires: php-spl
# remirepo:1
-%if 0%{?fedora} > 21
+%if 0%{?fedora} > 21 || 0%{?rhel} >= 8
Recommends: php-phpunit-dbunit4
#Suggests: php-phpunit-selenium
# remirepo:1
@@ -208,7 +208,10 @@ cat << 'EOF' | tee -a src/autoload.php
'%{ns_vendor}/Framework/MockObject6/autoload.php',
'%{php_home}/Prophecy/autoload.php',
'%{php_home}/SebastianBergmann/Diff3/autoload.php', // Before comparator which may load v2
- '%{php_home}/SebastianBergmann/Comparator2/autoload.php',
+ [
+ '%{php_home}/SebastianBergmann/Comparator3/autoload.php',
+ '%{php_home}/SebastianBergmann/Comparator2/autoload.php',
+ ],
'%{php_home}/SebastianBergmann/Environment3/autoload.php',
'%{php_home}/SebastianBergmann/Exporter3/autoload.php',
'%{php_home}/SebastianBergmann/GlobalState2/autoload.php',
@@ -266,6 +269,10 @@ exit $ret
%changelog
+* Wed Apr 18 2018 Remi Collet <remi@remirepo.net> - 7.1.4-1
+- update to 7.1.4
+- allow sebastian/comparator 3.0
+
* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 7.1.3-1
- update to 7.1.3 (no change)
- raise dependency on phpunit/phpunit-mock-objects 6.1.1