summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-18 16:34:37 +0200
committerRemi Collet <remi@remirepo.net>2018-10-18 16:34:37 +0200
commit72e52cfa39010f7d5fb81c7054b4ef609b43dec4 (patch)
treeb787ae564eb4d345fb230e30ac901f211ee739f5
parentf024463bfd96d093dc0862be01673c8d4293ab83 (diff)
add patch for https://github.com/sebastianbergmann/phpunit/issues/3354
from https://github.com/sebastianbergmann/phpunit/pull/3355
-rw-r--r--3355.patch24
-rw-r--r--phpunit7.spec8
2 files changed, 31 insertions, 1 deletions
diff --git a/3355.patch b/3355.patch
new file mode 100644
index 0000000..9cfaa05
--- /dev/null
+++ b/3355.patch
@@ -0,0 +1,24 @@
+Adapted for 7.4.1 from
+
+From 03e86defca1096cfbbf9962c1151773ac8767fcb Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 18 Oct 2018 14:58:51 +0200
+Subject: [PATCH] Fix #3354
+
+---
+ src/TextUI/TestRunner.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/TextUI/TestRunner.php b/src/TextUI/TestRunner.php
+index 00c2fcf860..bc167dd14e 100644
+--- a/src/TextUI/TestRunner.php
++++ b/src/TextUI/TestRunner.php
+@@ -158,7 +158,7 @@ class TestRunner extends BaseTestRunner
+
+ $this->handleConfiguration($arguments);
+
+- if ($arguments['columns'] < 16) {
++ if (\is_int($arguments['columns']) && $arguments['columns'] < 16) {
+ $arguments['columns'] = 16;
+ $tooFewColumnsRequested = true;
+ }
diff --git a/phpunit7.spec b/phpunit7.spec
index 8e5f171..b1ec880 100644
--- a/phpunit7.spec
+++ b/phpunit7.spec
@@ -25,7 +25,7 @@
%global ver_major 7
%global ver_minor 4
%global ver_patch 1
-%global specrel 1
+%global specrel 2
Name: %{pk_project}%{ver_major}
Version: %{ver_major}.%{ver_minor}.%{ver_patch}
@@ -38,6 +38,7 @@ Source0: https://github.com/%{gh_vendor}/%{gh_project}/archive/%{gh_commi
# Fix command for autoload
Patch0: %{name}-rpm.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/sebastianbergmann/phpunit/pull/3355.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.1
@@ -193,6 +194,7 @@ It is an instance of the xUnit architecture for unit testing frameworks.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0 -b .rpm
+%patch1 -p1
%build
@@ -276,6 +278,10 @@ exit $ret
%changelog
+* Thu Oct 18 2018 Remi Collet <remi@remirepo.net> - 7.4.1-2
+- add patch for https://github.com/sebastianbergmann/phpunit/issues/3354
+ from https://github.com/sebastianbergmann/phpunit/pull/3355
+
* Thu Oct 18 2018 Remi Collet <remi@remirepo.net> - 7.4.1-1
- update to 7.4.1
- allow sebastian/environment 4