summaryrefslogtreecommitdiffstats
path: root/php-phpunit-php-timer2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpunit-php-timer2.spec')
-rw-r--r--php-phpunit-php-timer2.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php-phpunit-php-timer2.spec b/php-phpunit-php-timer2.spec
index 05fbf6f..0fc1c1c 100644
--- a/php-phpunit-php-timer2.spec
+++ b/php-phpunit-php-timer2.spec
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 1038454804406b0b5f5f520358e78c1c2f71501e
+%global gh_commit 2454ae1765516d20c4ffe103d85a58a9a3bd5662
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
@@ -28,7 +28,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.1.2
+Version: 2.1.3
Release: 1%{?dist}
Summary: PHP Utility class for timing
@@ -37,16 +37,16 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
-BuildRequires: php(language) >= 7.1
+BuildRequires: php(language) >= 7.2
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# From composer.json"require-dev": {
-# "phpunit/phpunit": "^7.0"
-BuildRequires: phpunit7
+# "phpunit/phpunit": "^8.5"
+BuildRequires: phpunit8 >= 8.5
%endif
# From composer.json
-# "php": "^7.1"
+# "php": ">=7.1"
Requires: php(language) >= 7.1
# From phpcompatinfo report for version 2.0.0
Requires: php-spl
@@ -84,10 +84,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php \
- %{_bindir}/phpunit7 --verbose || ret=1
+ %{_bindir}/phpunit8 --verbose || ret=1
fi
done
exit $ret
@@ -105,6 +105,10 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 2.1.3-1
+- update to 2.1.3 (no change)
+- switch to phpunit8
+
* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 2.1.2-1
- update to 2.1.2
- drop patch merged upstream