summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-01 15:33:48 +0100
committerRemi Collet <remi@php.net>2024-03-01 15:33:48 +0100
commit50d30740fbcfbf030c30feb3dd9a488447322ac4 (patch)
treeef0311339df2c6adcc1a83d0240a61762d8ca97b
parentac9e0ee4177050e0e114d263b9c4a89cea51dc3d (diff)
update to 2.1.4 (no change)HEADmaster
sources from git snapshot
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-phpunit-php-timer2.spec17
2 files changed, 39 insertions, 6 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..3d8028d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-phpunit-php-timer2.spec b/php-phpunit-php-timer2.spec
index 0d7ccf8..ce88082 100644
--- a/php-phpunit-php-timer2.spec
+++ b/php-phpunit-php-timer2.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpunit-php-timer2
#
-# Copyright (c) 2010-2023 Christof Damian, Remi Collet
+# Copyright (c) 2010-2024 Christof Damian, Remi Collet
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -8,7 +8,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 2454ae1765516d20c4ffe103d85a58a9a3bd5662
+%global gh_commit a691211e94ff39a34811abd521c31bd5b305b0bb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project php-timer
@@ -28,13 +28,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.1.3
-Release: 7%{?dist}
+Version: 2.1.4
+Release: 1%{?dist}
Summary: PHP Utility class for timing
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.2
@@ -84,7 +85,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php80 php81 php82; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php \
%{_bindir}/phpunit8 --verbose || ret=1
@@ -105,6 +106,10 @@ exit $ret
%changelog
+* Fri Mar 1 2024 Remi Collet <remi@remirepo.net> - 2.1.4-1
+- update to 2.1.4 (no change)
+- sources from git snapshot
+
* Thu Apr 20 2023 Remi Collet <remi@remirepo.net> - 2.1.3-7
- use SPDX license ID