summaryrefslogtreecommitdiffstats
path: root/php-zumba-json-serializer.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-26 07:59:05 +0200
committerRemi Collet <remi@php.net>2023-09-26 07:59:05 +0200
commitf4a63b71512146fc0329381176f200c7fb82395a (patch)
treeba5b202c6ce98142fa1296002ecf98061b09253f /php-zumba-json-serializer.spec
parentad345036f0e613156427357a5916f8dea851a99e (diff)
update to 3.2.0
sources from git snapshot switch to phpunit10
Diffstat (limited to 'php-zumba-json-serializer.spec')
-rw-r--r--php-zumba-json-serializer.spec25
1 files changed, 19 insertions, 6 deletions
diff --git a/php-zumba-json-serializer.spec b/php-zumba-json-serializer.spec
index 683d70f..abdfc9b 100644
--- a/php-zumba-json-serializer.spec
+++ b/php-zumba-json-serializer.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 3d9f1b7ac4ce46107db500f3cc1384217ddf1649
+%global gh_commit 93786164efd20b6e01d42b03d4f7c2e52c9cebd8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zumba
%global gh_project json-serializer
@@ -18,13 +18,14 @@
%global major %nil
Name: php-%{gh_owner}-%{gh_project}%{major}
-Version: 3.1.0
+Version: 3.2.0
Release: 1%{?dist}
Summary: Serialize PHP variables
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{?gh_short}.tar.gz
+Source0: %{name}-%{version}-%{?gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
%if %{with tests}
@@ -36,10 +37,17 @@ BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": ">=6.0 <10.0"
+# "phpunit/phpunit": ">=6.0 <11.0"
+# remirepo:1
+%if 0%{?fedora} >= 38
+BuildRequires: phpunit10
+%global phpunit %{_bindir}/phpunit10
+# remirepo:4
+%else
BuildRequires: phpunit9
%global phpunit %{_bindir}/phpunit9
%endif
+%endif
# For autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -95,10 +103,10 @@ EOF
ret=0
# ignore testS relying on SuperClosure (deprecated and removed from repo)
-for cmdarg in "php %{phpunit}" php80 php81 php82 php83; do
+for cmdarg in "php %{phpunit}" "php80 %{_bindir}/phpunit9" php81 php82 php83; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} \
+ $1 ${2:-%{_bindir}/phpunit10} \
--bootstrap vendor/autoload.php \
--filter '^((?!(testAddSerializer|testGetPreferredSerializer|testSerialize|testUnserialize)).)*$' \
--no-coverage || ret=1
@@ -121,6 +129,11 @@ exit $ret
%changelog
+* Tue Sep 26 2023 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+- sources from git snapshot
+- switch to phpunit10
+
* Tue Jul 18 2023 Remi Collet <remi@remirepo.net> - 3.1.0-1
- update to 3.1.0