summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-13 09:16:36 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-13 09:16:36 +0200
commit91bad9cb4d4dd1e068f2be01deaa98cb1457f68d (patch)
tree76cd29a7e19665be0f8d249b9126288e86b95a63
parent37b1873b97194562cc7fcbe87a09f56419fba251 (diff)
php-zordius-lightncandy: backport
-rw-r--r--Makefile4
-rw-r--r--php-zordius-lightncandy.spec22
2 files changed, 26 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-zordius-lightncandy.spec b/php-zordius-lightncandy.spec
index 96ba798..517fc85 100644
--- a/php-zordius-lightncandy.spec
+++ b/php-zordius-lightncandy.spec
@@ -1,3 +1,12 @@
+# remirepo spec file for php-zordius-lightncandy, from
+#
+# Fedora spec file for php-zordius-lightncandy
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
%global handlebars_git df077dd262eea766648af0b6efd8a22e44c78178
%global mustache_git 83b0721610a4e11832e83df19c73ace3289972b9
@@ -5,6 +14,7 @@ Name: php-zordius-lightncandy
Version: 0.22
Release: 1%{?dist}
Summary: An extremely fast PHP implementation of handlebars and mustache
+Group: Development/Libraries
License: MIT
URL: https://github.com/zordius/lightncandy
@@ -13,6 +23,7 @@ Source0: https://github.com/zordius/lightncandy/archive/v%{version}.tar.gz#/%{na
Source1: https://github.com/kasperisager/handlebars-spec/archive/%{handlebars_git}.tar.gz#/%{name}-handlebars.tar.gz
Source2: https://github.com/mustache/spec/archive/%{mustache_git}.tar.gz#/%{name}-mustache.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-phpunit-PHPUnit
@@ -43,6 +54,8 @@ phpab --output src/autoload.php src
%install
+rm -rf %{buildroot}
+
mkdir -pm 0755 %{buildroot}%{_datadir}/php/zordius/lightncandy
cp -p src/autoload.php %{buildroot}%{_datadir}/php/zordius/lightncandy
cp -p src/lightncandy.php %{buildroot}%{_datadir}/php/zordius/lightncandy
@@ -52,13 +65,22 @@ cp -p src/lightncandy.php %{buildroot}%{_datadir}/php/zordius/lightncandy
phpunit -v --filter test
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
%license LICENSE.txt
%doc composer.json CONTRIBUTING.md HISTORY.md README.md UPGRADE.md
%{_datadir}/php/zordius
%changelog
+* Tue Oct 13 2015 Remi Collet <remi@fedoraproject.org> - 0.22-1
+- backport for remi repo, add EL-5 stuff
+
* Fri Oct 09 2015 Michael Cronenworth <mike@cchtml.com> - 0.22-1
- Initial package