summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-18 14:58:50 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-18 14:58:50 +0200
commit0abe7b281b894b79ecdf2c3618ec29dfb3e3f595 (patch)
tree0aa4faf4746ebd07b014a16bd326f0748ade9750
parent54ac2d836b399f555ed798a0a0a27c1eeaa0340e (diff)
php-znerol-php-stringprep: add fix for autoload
-rw-r--r--Stringprep-pr6.patch99
-rw-r--r--php-znerol-php-stringprep.spec11
2 files changed, 109 insertions, 1 deletions
diff --git a/Stringprep-pr6.patch b/Stringprep-pr6.patch
new file mode 100644
index 0000000..9380abb
--- /dev/null
+++ b/Stringprep-pr6.patch
@@ -0,0 +1,99 @@
+From 5ffb9c2b3b887e99f6b880b032f2c81885d9d32c Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Thu, 18 Jun 2015 14:27:29 +0200
+Subject: [PATCH] Fix #5 autoload issue
+
+---
+ Profile/ISCSI.php | 1 +
+ Profile/Nameprep.php | 1 +
+ Profile/Nodeprep.php | 1 +
+ Profile/PolicyMIB.php | 1 +
+ Profile/Resourceprep.php | 1 +
+ Profile/SASLprep.php | 1 +
+ Profile/Trace.php | 1 +
+ 7 files changed, 7 insertions(+)
+
+diff --git a/Profile/ISCSI.php b/Profile/ISCSI.php
+index 7a2ee50..e599663 100644
+--- a/Profile/ISCSI.php
++++ b/Profile/ISCSI.php
+@@ -1,6 +1,7 @@
+ <?php
+
+ namespace Znerol\Component\Stringprep\Profile;
++use Znerol\Component\Stringprep\Profile;
+
+ /**
+ * Stringprep profile for iSCSI defined in RFC 3722
+diff --git a/Profile/Nameprep.php b/Profile/Nameprep.php
+index 8593f34..ea4f6b8 100644
+--- a/Profile/Nameprep.php
++++ b/Profile/Nameprep.php
+@@ -1,6 +1,7 @@
+ <?php
+
+ namespace Znerol\Component\Stringprep\Profile;
++use Znerol\Component\Stringprep\Profile;
+
+ /**
+ * Stringprep profile for nameprep defined in RFC 3491
+diff --git a/Profile/Nodeprep.php b/Profile/Nodeprep.php
+index fe468c9..318136a 100644
+--- a/Profile/Nodeprep.php
++++ b/Profile/Nodeprep.php
+@@ -1,6 +1,7 @@
+ <?php
+
+ namespace Znerol\Component\Stringprep\Profile;
++use Znerol\Component\Stringprep\Profile;
+
+ /**
+ * XMPP Nodeprep profile for nameprep defined in RFC 6122, Appendix A
+diff --git a/Profile/PolicyMIB.php b/Profile/PolicyMIB.php
+index 84d9b75..0cf405f 100644
+--- a/Profile/PolicyMIB.php
++++ b/Profile/PolicyMIB.php
+@@ -1,6 +1,7 @@
+ <?php
+
+ namespace Znerol\Component\Stringprep\Profile;
++use Znerol\Component\Stringprep\Profile;
+
+ /**
+ * XMPP PolicyMIB profile for stringprep defined in RFC 4011, Section 9.1.1
+diff --git a/Profile/Resourceprep.php b/Profile/Resourceprep.php
+index 8b1686a..64e62e3 100644
+--- a/Profile/Resourceprep.php
++++ b/Profile/Resourceprep.php
+@@ -1,6 +1,7 @@
+ <?php
+
+ namespace Znerol\Component\Stringprep\Profile;
++use Znerol\Component\Stringprep\Profile;
+
+ /**
+ * XMPP Resourceprep profile for stringprep defined in RFC 6122, Appendix B
+diff --git a/Profile/SASLprep.php b/Profile/SASLprep.php
+index f051239..2078630 100644
+--- a/Profile/SASLprep.php
++++ b/Profile/SASLprep.php
+@@ -1,6 +1,7 @@
+ <?php
+
+ namespace Znerol\Component\Stringprep\Profile;
++use Znerol\Component\Stringprep\Profile;
+
+ /**
+ * SASLprep: Stringprep Profile for User Names and Passwords, RFC 4013
+diff --git a/Profile/Trace.php b/Profile/Trace.php
+index 2e011aa..61fe643 100644
+--- a/Profile/Trace.php
++++ b/Profile/Trace.php
+@@ -1,6 +1,7 @@
+ <?php
+
+ namespace Znerol\Component\Stringprep\Profile;
++use Znerol\Component\Stringprep\Profile;
+
+ /**
+ * The "trace" Profile of "Stringprep" as defined in RFC 4505
diff --git a/php-znerol-php-stringprep.spec b/php-znerol-php-stringprep.spec
index 722c3f0..ab0bcad 100644
--- a/php-znerol-php-stringprep.spec
+++ b/php-znerol-php-stringprep.spec
@@ -18,7 +18,7 @@
Name: php-znerol-php-stringprep
Version: 0
-Release: 0.1.%{gh_date}git%{gh_short}%{?dist}
+Release: 0.2.%{gh_date}git%{gh_short}%{?dist}
Summary: Implementation of RFC 3454 Preparation of Internationalized Strings
Group: Development/Libraries
@@ -26,6 +26,9 @@ License: LGPLv3
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+# https://github.com/znerol/Stringprep/pull/6
+Patch0: %{gh_project}-pr6.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
@@ -56,6 +59,8 @@ See: http://tools.ietf.org/html/rfc3454
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
+
%build
# Generate a simple autoloader
@@ -94,6 +99,10 @@ rm -rf %{buildroot}
%changelog
+* Thu Jun 18 2015 Remi Collet <remi@fedoraproject.org> - 0-0.2.20150519git804b0d5
+- add patch for autoload issue
+ https://github.com/znerol/Stringprep/pull/6
+
* Tue May 19 2015 Remi Collet <remi@fedoraproject.org> - 0-0.1.20150519git804b0d5
- new snapshot (License PR merged)