summaryrefslogtreecommitdiffstats
path: root/php-zetacomponents-unit-test.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zetacomponents-unit-test.spec')
-rw-r--r--php-zetacomponents-unit-test.spec60
1 files changed, 35 insertions, 25 deletions
diff --git a/php-zetacomponents-unit-test.spec b/php-zetacomponents-unit-test.spec
index 92bdbad..6a8bcd5 100644
--- a/php-zetacomponents-unit-test.spec
+++ b/php-zetacomponents-unit-test.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-zetacomponents-unit-test
#
-# Copyright (c) 2015-2017 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2024 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 075742e2ad692c58da4dc593518a4d110f7eb822
+%global gh_commit ba9fd9e050d822c590a87f6c3cf31d60f556209e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zetacomponents
%global gh_project UnitTest
@@ -15,31 +15,25 @@
%global ezcdir %{_datadir}/php/ezc
Name: php-%{gh_owner}-%{cname}
-Version: 1.0.2
-Release: 2%{?dist}
+Version: 1.2.5
+Release: 1%{?dist}
Summary: Zeta UnitTest Component
-Group: Development/Libraries
-License: ASL 2.0
+License: Apache-2.0
URL: http://zetacomponents.org/
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
-# https://github.com/zetacomponents/UnitTest/pull/5
-Patch0: %{name}-pr5.patch
-# Upstream
-Patch1: %{name}-upstream.patch
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-BuildRequires: %{_bindir}/phpab
+BuildRequires: php-fedora-autoloader-devel
# From phpcompatinfo report for 1.0.2
Requires: php(language) > 5.3
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
-Requires: php-composer(phpunit/phpunit)
+Requires: phpunit9
# Also use Exception for Base, skipped to avoid circular dep.
+Requires: php-composer(fedora/autoloader)
Provides: php-composer(%{gh_owner}/%{cname}) = %{version}
@@ -56,19 +50,16 @@ the mailing list.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
-%patch1 -p1
-
%build
: Generate a simple autoloader
%{_bindir}/phpab \
+ --template fedora \
--output src/autoloader.php \
src
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{ezcdir}/autoload
: The library
@@ -79,12 +70,8 @@ cp -pr src/*_autoload.php \
%{buildroot}%{ezcdir}/autoload
-%clean
-rm -rf %{buildroot}
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE* CREDITS
%doc ChangeLog
@@ -97,10 +84,33 @@ rm -rf %{buildroot}
%changelog
+* Tue Jan 23 2024 Remi Collet <remi@remirepo.net> - 1.2.5-1
+- update to 1.2.5
+
+* Tue Jul 19 2022 Remi Collet <remi@remirepo.net> - 1.2.4-1
+- update to 1.2.4
+
+* Mon Jul 18 2022 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+- switch to phpunit9
+
+* Tue Feb 15 2022 Remi Collet <remi@remirepo.net> - 1.1.7-1
+- update to 1.1.7
+
+* Mon Jan 24 2022 Remi Collet <remi@remirepo.net> - 1.1.5-1
+- update to 1.1.5
+
+* Mon Aug 9 2021 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+- switch to phpunit8
+
+* Wed Feb 27 2019 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+
* Thu Jun 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-2
- add upstream patch for LICENSE file
* Wed Jun 3 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
- initial package
- open https://github.com/zetacomponents/UnitTest/issues/4 License
-- open https://github.com/zetacomponents/UnitTest/pull/5 phpunit 4 \ No newline at end of file
+- open https://github.com/zetacomponents/UnitTest/pull/5 phpunit 4