summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-08-09 09:44:49 +0200
committerRemi Collet <remi@remirepo.net>2021-08-09 09:44:49 +0200
commit86f03cb529a6ee38feb261efac9abc0d4c1180ee (patch)
treebeba7870e87f9cb9b14723e0745de2842da82c85
parent55fb1c583a268826d900890841d1e09b9a0f9515 (diff)
update to 1.1.3
switch to phpunit8
-rw-r--r--composer.json2
-rw-r--r--php-zetacomponents-unit-test.spec12
2 files changed, 9 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 685edce..61169a4 100644
--- a/composer.json
+++ b/composer.json
@@ -42,6 +42,6 @@
"name": "zetacomponents/unit-test",
"type": "library",
"require": {
- "phpunit/phpunit": "^7.0"
+ "phpunit/phpunit": "^8.0"
}
}
diff --git a/php-zetacomponents-unit-test.spec b/php-zetacomponents-unit-test.spec
index bde5867..d5c0969 100644
--- a/php-zetacomponents-unit-test.spec
+++ b/php-zetacomponents-unit-test.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-zetacomponents-unit-test
#
-# Copyright (c) 2015-2019 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 95f0c2e113994f88ab866779d673e285d3da7e66
+%global gh_commit 58171749418ca693d20733fa9a3fde4d32780b54
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zetacomponents
%global gh_project UnitTest
@@ -15,7 +15,7 @@
%global ezcdir %{_datadir}/php/ezc
Name: php-%{gh_owner}-%{cname}
-Version: 1.1.2
+Version: 1.1.3
Release: 1%{?dist}
Summary: Zeta UnitTest Component
@@ -31,7 +31,7 @@ Requires: php(language) > 5.3
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
-Requires: php-composer(phpunit/phpunit)
+Requires: phpunit8
# Also use Exception for Base, skipped to avoid circular dep.
Requires: php-composer(fedora/autoloader)
@@ -84,6 +84,10 @@ cp -pr src/*_autoload.php \
%changelog
+* Mon Aug 9 2021 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+- switch to phpunit8
+
* Wed Feb 27 2019 Remi Collet <remi@remirepo.net> - 1.1.2-1
- update to 1.1.2