summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-07-18 15:50:09 +0200
committerRemi Collet <remi@php.net>2022-07-18 15:50:09 +0200
commit2eec10be8cd7accb9f6f4ebf6efa797dde8ca433 (patch)
tree33636456c9c6b5b9c5db268d2ce8cc391f50d155
parent0e9a292baf5296f62b4cb68ab06bf64971d41d6d (diff)
update to 1.2.3
switch to phpunit9
-rw-r--r--composer.json10
-rw-r--r--php-zetacomponents-unit-test.spec8
2 files changed, 15 insertions, 3 deletions
diff --git a/composer.json b/composer.json
index 61169a4..a1ab965 100644
--- a/composer.json
+++ b/composer.json
@@ -42,6 +42,14 @@
"name": "zetacomponents/unit-test",
"type": "library",
"require": {
- "phpunit/phpunit": "^8.0"
+ "phpunit/phpunit": "^9.0"
+ },
+ "require-dev": {
+ "zetacomponents/coding-standard": "^1.0"
+ },
+ "config": {
+ "allow-plugins": {
+ "dealerdirect/phpcodesniffer-composer-installer": true
+ }
}
}
diff --git a/php-zetacomponents-unit-test.spec b/php-zetacomponents-unit-test.spec
index e87e428..f93ddf1 100644
--- a/php-zetacomponents-unit-test.spec
+++ b/php-zetacomponents-unit-test.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit 0f3f429e33ce4b5e92f1363557da79528bc8a49e
+%global gh_commit cb521e9197ce5a3b6daab2d8fa006c9f97a05275
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zetacomponents
%global gh_project UnitTest
@@ -15,7 +15,7 @@
%global ezcdir %{_datadir}/php/ezc
Name: php-%{gh_owner}-%{cname}
-Version: 1.1.7
+Version: 1.2.3
Release: 1%{?dist}
Summary: Zeta UnitTest Component
@@ -84,6 +84,10 @@ cp -pr src/*_autoload.php \
%changelog
+* Mon Jul 18 2022 Remi Collet <remi@remirepo.net> - 1.2.3-1
+- update to 1.2.3
+- switch to phpunit9
+
* Tue Feb 15 2022 Remi Collet <remi@remirepo.net> - 1.1.7-1
- update to 1.1.7