summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-15 10:31:20 +0100
committerRemi Collet <remi@php.net>2022-02-15 10:31:20 +0100
commit8f818a3eeb5ae2b1bd9e47cf7aca431b589246ae (patch)
tree35be071ad5647bb3287795e347a67c53426e60bd
parent4cbd97ef08e45bacd3d0d0b30a425b0d2fac2a07 (diff)
update to 1.3.3HEADmaster
-rw-r--r--composer.json13
-rw-r--r--php-zetacomponents-document.spec34
2 files changed, 23 insertions, 24 deletions
diff --git a/composer.json b/composer.json
index 34584fb..494c3d0 100644
--- a/composer.json
+++ b/composer.json
@@ -26,10 +26,11 @@
"license": "Apache-2.0",
"name": "zetacomponents/document",
"type": "library",
- "require": {
- "zetacomponents/base": "*"
- },
- "require-dev": {
- "zetacomponents/unit-test": "dev-master"
- }
+ "require": {
+ "zetacomponents/base": "~1.8"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~8.0",
+ "zetacomponents/unit-test": "*"
+ }
}
diff --git a/php-zetacomponents-document.spec b/php-zetacomponents-document.spec
index 365d99d..4490c17 100644
--- a/php-zetacomponents-document.spec
+++ b/php-zetacomponents-document.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-zetacomponents-document
#
-# Copyright (c) 2017-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2022 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,34 +12,29 @@
%global github_owner zetacomponents
%global github_name Document
-%global github_version 1.3.1
-%global github_commit 688abfde573cf3fe0730f82538fbd7aa9fc95bc8
+%global github_version 1.3.3
+%global github_commit 196884f00871ea7dcbca9ab8bc85716f626e9cc3
%global composer_vendor zetacomponents
%global composer_project document
-# "zetacomponents/base": "*"
+# "zetacomponents/base": "~1.8"
# NOTE: Min and max versions added to contain to one major version.
-%global zetacomponents_base_min_ver 1.0
+%global zetacomponents_base_min_ver 1.8
%global zetacomponents_base_max_ver 2.0
# "zetacomponents/unit-test": "dev-master"
# NOTE: Min and max versions added to contain to one major version.
%global zetacomponents_unit_test_min_ver 1.0
%global zetacomponents_unit_test_max_ver 2.0
-%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
# Build using "--with tests" to enable tests
-%global with_tests 0%{?_with_tests:1}
-%else
-# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
-%endif
+%bcond_with tests
%global ezcdir %{_datadir}/php/ezc
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Provides a general conversion framework for different documents
Group: Development/Libraries
@@ -51,7 +46,7 @@ BuildArch: noarch
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# Tests
-%if %{with_tests}
+%if %{with tests}
## composer.json
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(zetacomponents/base) >= %{zetacomponents_base_min_ver} with php-composer(zetacomponents/base) < %{zetacomponents_base_max_ver})
@@ -64,7 +59,7 @@ BuildRequires: php-composer(zetacomponents/unit-test) >= %{zetacomponents_unit_t
%endif
## phpcompatinfo (computed from version 1.3.1)
BuildRequires: php(language) >= 5.3.0
-BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: phpunit8
BuildRequires: php-ctype
BuildRequires: php-date
BuildRequires: php-dom
@@ -158,7 +153,7 @@ cp -pr src/*_autoload.php \
%check
-%if %{with_tests}
+%if %{with tests}
: Create tests bootstrap
cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
@@ -185,8 +180,8 @@ sed 's/function testLoadXmlDocumentFromFile/function SKIP_testLoadXmlDocumentFro
: Upstream tests
RETURN_CODE=0
-PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55} php56 php70 php71 php72; do
+PHPUNIT=$(which phpunit8)
+for PHP_EXEC in php php74 php80 php81; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --bootstrap bootstrap.php || RETURN_CODE=1
fi
@@ -199,7 +194,7 @@ exit $RETURN_CODE
%files
%{!?_licensedir:%global license %%doc}
-%license NOTICE
+%license LICENSE.txt
%doc *.rst
%doc ChangeLog
%doc composer.json
@@ -208,6 +203,9 @@ exit $RETURN_CODE
%changelog
+* Tue Feb 15 2022 Remi Collet <remi@remirepo.net> - 1.3.3-1
+- update to 1.3.3
+
* Mon May 28 2018 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.3.1-3
- Fix FTBS (RHBZ #1556121)
- Disable tests by default for F28+ and RHEL 8+