summaryrefslogtreecommitdiffstats
path: root/php-zetacomponents-console-tools.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zetacomponents-console-tools.spec')
-rw-r--r--php-zetacomponents-console-tools.spec50
1 files changed, 27 insertions, 23 deletions
diff --git a/php-zetacomponents-console-tools.spec b/php-zetacomponents-console-tools.spec
index 05d8dc6..a349833 100644
--- a/php-zetacomponents-console-tools.spec
+++ b/php-zetacomponents-console-tools.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-zetacomponents-console-tools
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 30d67e9d04f458ac8cae4c49e50f81061460ff2c
+%global gh_commit 1cee38174be119226727159bc8cf4ebb91b12a8e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zetacomponents
%global gh_project ConsoleTools
@@ -16,33 +16,41 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-%{gh_owner}-%{cname}
-Version: 1.7
-Release: 3%{?dist}
+Version: 1.7.1
+Release: 1%{?dist}
Summary: Zeta %{gh_project} Component
-Group: Development/Libraries
License: ASL 2.0
URL: http://zetacomponents.org/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-# Upstream patches
-Patch0: %{name}-upstream.patch
-# https://github.com/zetacomponents/ConsoleTools/pull/8
-Patch1: %{name}-pr8.patch
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: %{_bindir}/phpab
%if %{with_tests}
-BuildRequires: %{_bindir}/phpunit
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(%{gh_owner}/base) >= 1.8 with php-composer(%{gh_owner}/base) < 2)
+# remirepo:3
+%else
BuildRequires: php-composer(%{gh_owner}/base) >= 1.8
+%endif
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "~5.7",
+# "zetacomponents/unit-test": "*"
+BuildRequires: %{_bindir}/phpunit
BuildRequires: php-composer(%{gh_owner}/unit-test)
%endif
# From composer.json, "require": {
# "zetacomponents/base": "~1.8"
-Requires: php-composer(%{gh_owner}/base) >= 1.8
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(%{gh_owner}/base) >= 1.8 with php-composer(%{gh_owner}/base) < 2)
+# remirepo:4
+%else
Requires: php-composer(%{gh_owner}/base) < 2
+Requires: php-composer(%{gh_owner}/base) >= 1.8
+%endif
# From phpcompatinfo report for 1.7
Requires: php(language) > 5.3
Requires: php-iconv
@@ -73,9 +81,6 @@ Requires: %{name} = %{version}-%{release}
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
-%patch1 -p1
-
%build
: Generate a simple autoloader
@@ -89,7 +94,6 @@ EOF
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{ezcdir}/autoload
: The library
@@ -120,12 +124,8 @@ sed -e '/realpath/d' -i tests/statusbar_test.php
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE* CREDITS
%doc ChangeLog
@@ -139,6 +139,10 @@ rm -rf %{buildroot}
%changelog
+* Mon Mar 16 2020 Remi Collet <remi@remirepo.net> - 1.7.1-1
+- update to 1.7.1
+- use range dependencies
+
* Mon Jul 13 2015 Remi Collet <remi@fedoraproject.org> - 1.7-3
- create subpackage for documentation
- minor improvments, from review #1228091 comments
@@ -148,4 +152,4 @@ rm -rf %{buildroot}
* Wed Jun 3 2015 Remi Collet <remi@fedoraproject.org> - 1.7-1
- initial package
-- open https://github.com/zetacomponents/ConsoleTools/pull/8 interactive \ No newline at end of file
+- open https://github.com/zetacomponents/ConsoleTools/pull/8 interactive