summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-10-30 15:10:30 +0100
committerRemi Collet <remi@remirepo.net>2020-10-30 15:10:30 +0100
commitb40eb45cde8d610d0544412f2b4b7ba61f4f1095 (patch)
tree9e993ed4133fe70ecfe1e75e34c0c17eae4db7b2
parentdb9153d266c112626cd318ed89df9de11ba21888 (diff)
update to 1.7.2
switch to phpunit7
-rw-r--r--composer.json2
-rw-r--r--php-zetacomponents-console-tools.spec25
2 files changed, 18 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 872e08d..2b64ec0 100644
--- a/composer.json
+++ b/composer.json
@@ -50,7 +50,7 @@
"zetacomponents/base": "~1.8"
},
"require-dev": {
- "phpunit/phpunit": "~5.7",
+ "phpunit/phpunit": "~7.0",
"zetacomponents/unit-test": "*"
}
}
diff --git a/php-zetacomponents-console-tools.spec b/php-zetacomponents-console-tools.spec
index a0c37bd..8594d75 100644
--- a/php-zetacomponents-console-tools.spec
+++ b/php-zetacomponents-console-tools.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit 1cee38174be119226727159bc8cf4ebb91b12a8e
+%global gh_commit 97fb0743eb9aa3be76de01ce30503027840da55c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zetacomponents
%global gh_project ConsoleTools
@@ -16,7 +16,7 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-%{gh_owner}-%{cname}
-Version: 1.7.1
+Version: 1.7.2
Release: 1%{?dist}
Summary: Zeta %{gh_project} Component
@@ -32,12 +32,12 @@ BuildRequires: %{_bindir}/phpab
BuildRequires: (php-composer(%{gh_owner}/base) >= 1.8 with php-composer(%{gh_owner}/base) < 2)
# remirepo:3
%else
-BuildRequires: php-composer(%{gh_owner}/base) >= 1.8
+BuildRequires: php-zetacomponents-base >= 1.8
%endif
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~5.7",
+# "phpunit/phpunit": "~7.0",
# "zetacomponents/unit-test": "*"
-BuildRequires: %{_bindir}/phpunit
+BuildRequires: phpunit7
BuildRequires: php-composer(%{gh_owner}/unit-test)
%endif
@@ -48,8 +48,7 @@ BuildRequires: php-composer(%{gh_owner}/unit-test)
Requires: (php-composer(%{gh_owner}/base) >= 1.8 with php-composer(%{gh_owner}/base) < 2)
# remirepo:4
%else
-Requires: php-composer(%{gh_owner}/base) < 2
-Requires: php-composer(%{gh_owner}/base) >= 1.8
+Requires: php-zetacomponents-base >= 1.8
%endif
# From phpcompatinfo report for 1.7
Requires: php(language) > 5.3
@@ -118,7 +117,13 @@ EOF
sed -e '/realpath/d' -i tests/statusbar_test.php
: Run test test suite
-%{_bindir}/phpunit --exclude-group interactive
+for cmd in php php72 php73 php74 php80
+do
+ if which $cmd;
+ then
+ $cmd %{_bindir}/phpunit7 --exclude-group interactive
+ fi
+done
%else
: Test suite disabled
%endif
@@ -138,6 +143,10 @@ sed -e '/realpath/d' -i tests/statusbar_test.php
%changelog
+* Fri Oct 30 2020 Remi Collet <remi@remirepo.net> - 1.7.2-1
+- update to 1.7.2
+- switch to phpunit7
+
* Mon Mar 16 2020 Remi Collet <remi@remirepo.net> - 1.7.1-1
- update to 1.7.1
- use range dependencies