summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-13 10:56:09 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-13 10:56:09 +0200
commit7580112eb482fe15bbb8366c95b4f3384fa65d53 (patch)
tree84660b6ab3d21a104288ed17582efcead7891f53
parent6fa1d9b032cd0432d35f34d183fa40591010706a (diff)
php-zetacomponents-console-tools: comments from review
-rw-r--r--php-zetacomponents-console-tools.spec31
1 files changed, 26 insertions, 5 deletions
diff --git a/php-zetacomponents-console-tools.spec b/php-zetacomponents-console-tools.spec
index c275618..8e702e7 100644
--- a/php-zetacomponents-console-tools.spec
+++ b/php-zetacomponents-console-tools.spec
@@ -17,7 +17,7 @@
Name: php-%{gh_owner}-%{cname}
Version: 1.7
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Zeta %{gh_project} Component
Group: Development/Libraries
@@ -35,7 +35,6 @@ BuildArch: noarch
BuildRequires: %{_bindir}/phpab
%if %{with_tests}
BuildRequires: %{_bindir}/phpunit
-BuildRequires: php-gd
BuildRequires: php-composer(%{gh_owner}/base) >= 1.8
BuildRequires: php-composer(%{gh_owner}/unit-test)
%endif
@@ -58,6 +57,18 @@ A set of classes to do different actions with the console, also called shell.
It can render a progress bar, tables and a status bar and contains a class for
parsing command line options.
+Documentation is available in the %{name}-doc package.
+
+
+%package doc
+Summary: Documentation for %{name}
+Group: Documentation
+# For License
+Requires: %{name} = %{version}-%{release}
+
+%description doc
+%{summary}.
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -73,7 +84,7 @@ parsing command line options.
src
cat <<EOF | tee -a src/autoloader.php
# Dependencies
-require_once 'ezc/Base/autoloader.php';
+require_once '%{ezcdir}/Base/autoloader.php';
EOF
@@ -96,9 +107,12 @@ mkdir vendor
cat <<EOF | tee vendor/autoload.php
<?php
require '%{ezcdir}/UnitTest/autoloader.php';
-require '$PWD/src/autoloader.php';
+require '%{buildroot}%{ezcdir}/%{gh_project}/autoloader.php';
EOF
+: Drop assertion which rely on path in sources dir
+sed -e '/realpath/d' -i tests/statusbar_test.php
+
: Run test test suite
%{_bindir}/phpunit --exclude-group interactive
%else
@@ -116,12 +130,19 @@ rm -rf %{buildroot}
%license LICENSE* CREDITS
%doc ChangeLog
%doc composer.json
-%doc docs design
%{ezcdir}/autoload/*
%{ezcdir}/%{gh_project}
+%files doc
+%defattr(-,root,root,-)
+%doc docs design
+
%changelog
+* Mon Jul 13 2015 Remi Collet <remi@fedoraproject.org> - 1.7-3
+- create subpackage for documentation
+- minor improvments, from review #1228091 comments
+
* Thu Jun 4 2015 Remi Collet <remi@fedoraproject.org> - 1.7-2
- fix summary