summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-19 13:58:20 +0100
committerRemi Collet <remi@php.net>2022-01-19 13:58:20 +0100
commit1d0d17da6491f83d4c9307e59d11d2d98755e1f8 (patch)
tree53b0a8191ca0e4bc89da236b7a34ff907543402e
parentfe516daf90e60f686781254c4c341253e46d4b82 (diff)
update to 1.7.3
-rw-r--r--composer.json2
-rw-r--r--php-zetacomponents-console-tools.spec20
2 files changed, 12 insertions, 10 deletions
diff --git a/composer.json b/composer.json
index 2b64ec0..2960440 100644
--- a/composer.json
+++ b/composer.json
@@ -50,7 +50,7 @@
"zetacomponents/base": "~1.8"
},
"require-dev": {
- "phpunit/phpunit": "~7.0",
+ "phpunit/phpunit": "~8.0",
"zetacomponents/unit-test": "*"
}
}
diff --git a/php-zetacomponents-console-tools.spec b/php-zetacomponents-console-tools.spec
index dfad87c..f418b6c 100644
--- a/php-zetacomponents-console-tools.spec
+++ b/php-zetacomponents-console-tools.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-zetacomponents-console-tools
#
-# Copyright (c) 2015-2021 Remi Collet
+# Copyright (c) 2015-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 97fb0743eb9aa3be76de01ce30503027840da55c
+%global gh_commit fbc31f1be66ccd178c68d846d7c0ae09dbb97c89
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zetacomponents
%global gh_project ConsoleTools
@@ -16,15 +16,14 @@
%if 0%{?fedora}
%bcond_without tests
-%bcond_without phpab
%else
%bcond_with tests
-%bcond_with phpab
%endif
+%bcond_without phpab
Name: php-%{gh_owner}-%{cname}
-Version: 1.7.2
-Release: 4%{?dist}
+Version: 1.7.3
+Release: 1%{?dist}
Summary: Zeta %{gh_project} Component
License: ASL 2.0
@@ -45,9 +44,9 @@ BuildRequires: (php-composer(%{gh_owner}/base) >= 1.8 with php-composer(%{gh_o
BuildRequires: php-zetacomponents-base >= 1.8
%endif
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~7.0",
+# "phpunit/phpunit": "~8.0",
# "zetacomponents/unit-test": "*"
-BuildRequires: phpunit7
+BuildRequires: phpunit8
BuildRequires: php-composer(%{gh_owner}/unit-test)
%endif
@@ -135,7 +134,7 @@ for cmd in php php74 php80 php81
do
if which $cmd;
then
- $cmd %{_bindir}/phpunit7 --exclude-group interactive
+ $cmd %{_bindir}/phpunit8 --exclude-group interactive
fi
done
%else
@@ -157,6 +156,9 @@ done
%changelog
+* Wed Jan 19 2022 Remi Collet <remi@remirepo.net> - 1.7.3-1
+- update to 1.7.3
+
* Mon Dec 6 2021 Remi Collet <remi@remirepo.net> - 1.7.2-4
- disable test suite on EL
- add autoloader from sources on EL