summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-26 07:48:39 +0200
committerRemi Collet <remi@remirepo.net>2021-07-26 07:48:39 +0200
commit6e39555be7ad0c502c4ff4e8fe90d5273e6aefbe (patch)
treea9c582734d1831efafb65028401786bbecaa6f7a
parent810075add0462194cd3f4486797086b7b2071dd2 (diff)
update to 1.9.3
-rw-r--r--composer.json2
-rw-r--r--php-zetacomponents-base.spec17
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 94ff06f..3d9a189 100644
--- a/composer.json
+++ b/composer.json
@@ -42,7 +42,7 @@
"name": "zetacomponents/base",
"type": "library",
"require-dev": {
- "phpunit/phpunit": "~5.7",
+ "phpunit/phpunit": "~8.0",
"zetacomponents/unit-test": "*"
}
}
diff --git a/php-zetacomponents-base.spec b/php-zetacomponents-base.spec
index b759dfd..f90300d 100644
--- a/php-zetacomponents-base.spec
+++ b/php-zetacomponents-base.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-zetacomponents-base
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 489e20235989ddc97fdd793af31ac803972454f1
+%global gh_commit 2f432f4117a5aa2164d4fb1784f84db91dbdd3b8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zetacomponents
%global gh_project Base
@@ -16,14 +16,14 @@
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-%{gh_owner}-%{cname}
-Version: 1.9.1
+Version: 1.9.3
Release: 1%{?dist}
Summary: Zeta Base Component
Group: Development/Libraries
License: ASL 2.0
URL: http://zetacomponents.org/
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
# Use old PEAR layout
Patch0: %{name}-layout.patch
@@ -31,7 +31,7 @@ Patch0: %{name}-layout.patch
BuildArch: noarch
BuildRequires: %{_bindir}/phpab
%if %{with_tests}
-BuildRequires: %{_bindir}/phpunit
+BuildRequires: phpunit8
BuildRequires: %{_bindir}/convert
BuildRequires: php-composer(%{gh_owner}/unit-test)
BuildRequires: php-posix
@@ -92,9 +92,9 @@ EOF
: Run test test suite
ret=0
-for cmd in php php56 php70 php71 php72; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
- $cmd %{_bindir}/phpunit || ret=1
+ $cmd %{_bindir}/phpunit8 || ret=1
fi
done
exit $ret
@@ -116,6 +116,9 @@ exit $ret
%changelog
+* Mon Jul 26 2021 Remi Collet <remi@remirepo.net> - 1.9.3-1
+- update to 1.9.3
+
* Wed Nov 29 2017 Remi Collet <remi@remirepo.net> - 1.9.1-1
- Update to 1.9.1