summaryrefslogtreecommitdiffstats
path: root/php-zephir-parser.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-11-06 10:51:53 +0100
committerRemi Collet <remi@remirepo.net>2018-11-06 10:51:53 +0100
commit1edd263f2352536f78d1c76c6db0f196605d47a4 (patch)
tree4f22fc8e09c25cc7e5ef68d35f401e123d81e57e /php-zephir-parser.spec
parentd264d77adefb33d8490a5570c62ad4cde1f52084 (diff)
update to 1.1.3
add devel sub-package adopt standard php build system (phpize)
Diffstat (limited to 'php-zephir-parser.spec')
-rw-r--r--php-zephir-parser.spec44
1 files changed, 23 insertions, 21 deletions
diff --git a/php-zephir-parser.spec b/php-zephir-parser.spec
index 105e2df..5afe7bc 100644
--- a/php-zephir-parser.spec
+++ b/php-zephir-parser.spec
@@ -8,18 +8,11 @@
#
%if 0%{?scl:1}
-%global with_tests 0
%scl_package php-zephyr-parser
-%else
-%if 0%{?fedora}
-%global with_tests 0%{!?_without_tests:1}
-%else
-# Disable in EL as 5.5 can't use phpunit
-%global with_tests 0%{?_with_tests:1}
-%endif
%endif
-%global gh_commit c9ce3dffb3dce622a4015d400a517ababfb66462
+%global with_tests 0%{!?_without_tests:1}
+%global gh_commit ae0124b7ded64b4c1b9e487698297c7e7dcb7a8f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -27,17 +20,14 @@
%global ext_name zephir_parser
Name: %{?scl_prefix}%{gh_project}
-Version: 1.1.2
-Release: 2%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.1.3
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Zephir parser extension
License: MIT
URL: https://getcomposer.org/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-# honours RPM build flags and drop configure/make/install part
-Patch0: %{gh_project}-build.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 5.5
%if 0%{?rhel} == 6
@@ -58,11 +48,17 @@ Provides: %{?scl_prefix}zephir-parser = %{version}
The Zephir Parser delivered as a C extension for the PHP language.
+%package devel
+Summary: %{name} developer files (headers)
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: %{?scl_prefix}php-devel%{?_isa}
+
+%description devel
+These are the files needed to compile programs using %{name}.
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .rpm
-grep CFLAGS install && exit 1
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZEPHIR_PARSER_VERSION/{s/.* "//;s/".*$//;p}' zephir_parser.h)
@@ -75,11 +71,7 @@ fi
%build
%{?dtsenable}
-%{?scl:module load %{scl}}
-echo $PATH
-php-config --version
-./install
-
+%{_bindir}/phpize
%configure \
--with-php-config=%{_bindir}/php-config \
--enable-zephir_parser
@@ -116,7 +108,17 @@ REPORT_EXIT_STATUS=1 \
%{php_extdir}/%{ext_name}.so
+%files devel
+%{php_incldir}/ext/%{ext_name}
+
+
+
%changelog
+* Tue Nov 6 2018 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+- add devel sub-package
+- adopt standard php build system (phpize)
+
* Mon Feb 26 2018 Remi Collet <remi@remirepo.net> - 1.1.2-2
- use "module load ..." command instead of "scl enable ..."