summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-10 07:03:19 +0100
committerRemi Collet <remi@remirepo.net>2017-11-10 07:03:19 +0100
commit07bf8b7fdf8c478b456d639de004ede8973966fd (patch)
tree662e775e2384f4c64a661807361c991985513589
parenteda11ce9f13cd0582be607551a41e52c7b57c932 (diff)
v1.1.1
-rw-r--r--REFLECTION2
-rw-r--r--php-zephir-parser-build.patch21
-rw-r--r--php-zephir-parser.spec9
3 files changed, 19 insertions, 13 deletions
diff --git a/REFLECTION b/REFLECTION
index 8d8785c..b6d453c 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #185 Zephir Parser version 1.1.0 ] {
+Extension [ <persistent> extension #187 Zephir Parser version 1.1.1 ] {
- Functions {
Function [ <internal:Zephir Parser> function zephir_parse_file ] {
diff --git a/php-zephir-parser-build.patch b/php-zephir-parser-build.patch
index 6c16bcb..27c2ef1 100644
--- a/php-zephir-parser-build.patch
+++ b/php-zephir-parser-build.patch
@@ -1,15 +1,15 @@
diff -up ./install.rpm ./install
---- ./install.rpm 2017-10-12 11:26:32.000000000 +0200
-+++ ./install 2017-10-12 11:29:16.000000000 +0200
-@@ -33,7 +33,6 @@ fi
+--- ./install.rpm 2017-11-09 08:30:30.000000000 +0100
++++ ./install 2017-11-10 06:55:13.646045853 +0100
+@@ -50,7 +50,6 @@ fi
# Check best compilation flags for compiler
export CC=gcc
-export CFLAGS="-march=native -mtune=native -O2 -fomit-frame-pointer"
# Set defaults
- PHPIZE_BIN=$(command -v phpize 2>/dev/null)
-@@ -74,28 +73,6 @@ if [ "${PHP_FULL_VERSION:0:3}" == "5.4"
+ PHPIZE_BIN=`command -v phpize 2>/dev/null || true`
+@@ -91,28 +90,6 @@ if [ "${PHP_FULL_VERSION:0:3}" == "5.4"
exit 1
fi
@@ -38,12 +38,16 @@ diff -up ./install.rpm ./install
cd ${CURRENT_DIR}/parser
# Cleanup
-@@ -166,33 +143,3 @@ if [ "$(uname -s 2>/dev/null)" = "Darwin
- aclocal && ${LIBTOOLIZE_BIN} --force && autoheader && autoconf
+@@ -182,36 +159,3 @@ if [ "$(uname -s 2>/dev/null)" = "Darwin
+ aclocal && ${LIBTOOLIZE_BIN} --force && autoheader && autoconf
fi
--./configure --silent --with-php-config=${PHPCONFIG_BIN} --enable-zephir_parser
+-./configure \
+- --silent \
+- --with-php-config=${PHPCONFIG_BIN} \
+- --enable-zephir_parser
-
+-# Perform the compilation
-make -s -j"$(getconf _NPROCESSORS_ONLN)"
-make -s install
-
@@ -71,4 +75,3 @@ diff -up ./install.rpm ./install
- config.h.in~
-
-echo -e "\nThanks for compiling Zephir Parser!\nBuild succeed: Please restart your web server to complete the installation\n"
--
diff --git a/php-zephir-parser.spec b/php-zephir-parser.spec
index 3bd4402..d1da16d 100644
--- a/php-zephir-parser.spec
+++ b/php-zephir-parser.spec
@@ -19,7 +19,7 @@
%endif
%endif
-%global gh_commit 0d16308092c2ff663dfc73e44a654e64d66362be
+%global gh_commit 546b07e76d8ada2f5c4089813aa8a0b74fac280e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -27,7 +27,7 @@
%global ext_name zephir_parser
Name: %{?scl_prefix}%{gh_project}
-Version: 1.1.0
+Version: 1.1.1
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Zephir parser extension
@@ -104,12 +104,15 @@ REPORT_EXIT_STATUS=1 \
%files
%{!?_licensedir:%global license %%doc}
%license LICENSE
-%doc CREDITS
+%doc CREDITS NO_WARRANTY TODO
%doc *.md
%{php_extdir}/%{ext_name}.so
%changelog
+* Fri Nov 10 2017 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
* Thu Oct 12 2017 Remi Collet <remi@remirepo.net> - 1.1.0-1
- update to 1.1.0