summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-30 09:13:36 +0200
committerRemi Collet <remi@php.net>2023-08-30 09:13:36 +0200
commit4551fcdc4eb8318d481546f904fde6144a247910 (patch)
tree8db2778706e38d8cb459998637b83df09e2a8313
parent053685c037b12426a364f46e8638e0d0d9719399 (diff)
rebuild for PHP 8.3.0RC1HEADmaster
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION2
-rw-r--r--php-zephir-parser.spec51
3 files changed, 32 insertions, 25 deletions
diff --git a/PHPINFO b/PHPINFO
index 6a1d410..15c1fca 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,5 +5,5 @@ zephir_parser
The Zephir Parser delivered as a C extension for the PHP language.
zephir_parser => enabled
Author => Zephir Team and contributors
-Version => 1.5.3
-Build Date => Feb 9 2023 00:00:00
+Version => 1.6.0
+Build Date => Aug 28 2023 00:00:00
diff --git a/REFLECTION b/REFLECTION
index 3ea41e3..91c9ff1 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #107 zephir_parser version 1.5.3 ] {
+Extension [ <persistent> extension #110 zephir_parser version 1.6.0 ] {
- Functions {
Function [ <internal:zephir_parser> function zephir_parse_file ] {
diff --git a/php-zephir-parser.spec b/php-zephir-parser.spec
index fe9ae0d..557e537 100644
--- a/php-zephir-parser.spec
+++ b/php-zephir-parser.spec
@@ -21,15 +21,17 @@
%global pecl_name zephir_parser
%global ini_name 40-%{pecl_name}.ini
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global sources %{pecl_name}-%{version}
+%global _configure ../%{sources}/configure
Name: %{?scl_prefix}%{gh_project}
-Version: 1.5.3
-Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 1.6.0
+Release: 2%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Zephir code parser
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: http://pecl.php.net/get/%{pecl_name}-%{version}.tgz
+Source0: http://pecl.php.net/get/%{sources}.tgz
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
@@ -67,11 +69,10 @@ These are the files needed to compile programs using %{name}.
%prep
%setup -qc
-mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
-pushd NTS
+pushd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_ZEPHIR_PARSER_VERSION/{s/.* "//;s/".*$//;p}' zephir_parser.h)
if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
@@ -80,9 +81,9 @@ if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
fi
popd
+mkdir NTS
%if %{with_zts}
-# Duplicate source tree for NTS / ZTS build
-cp -pr NTS ZTS
+mkdir ZTS
%endif
# Create configuration file
@@ -95,10 +96,12 @@ EOF
%build
%{?dtsenable}
-pushd NTS
-%{_bindir}/phpize
+pushd %{sources}
+%{__phpize}
+
+cd ../NTS
%configure \
- --with-php-config=%{_bindir}/php-config \
+ --with-php-config=%{__phpconfig} \
--enable-zephir_parser
make %{?_smp_mflags}
@@ -106,9 +109,9 @@ popd
%if %{with_zts}
pushd ZTS
-%{_bindir}/zts-phpize
%configure \
- --with-php-config=%{_bindir}/zts-php-config
+ --with-php-config=%{__ztsphpconfig} \
+ --enable-zephir_parser
make %{?_smp_mflags}
popd
%endif
@@ -131,10 +134,10 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
# Tests & Documentation
for i in $(grep 'role="test"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_testdir}/%{pecl_name}/$i
done
for i in $(grep 'role="doc"' package.xml | sed -e 's/^.*name="//;s/".*$//')
-do install -Dpm 644 NTS/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
+do install -Dpm 644 %{sources}/$i %{buildroot}%{pecl_docdir}/%{pecl_name}/$i
done
@@ -159,10 +162,10 @@ fi
%check
-pushd NTS
+cd %{sources}
: Check extension
-%{_bindir}/php -n -d extension=modules/%{pecl_name}.so -m | grep "%{pecl_name}"
+%{__php} -n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so -m | grep '^%{pecl_name}$'
%if %{with tests}
: Run test suite
@@ -173,26 +176,23 @@ REPORT_EXIT_STATUS=1 \
%else
: Test suite disabled
%endif
-popd
%if %{with_zts}
-pushd ZTS
: Minimal load test for ZTS extension
-%{__ztsphp} -n -d extension=modules/%{pecl_name}.so -m | grep "%{pecl_name}"
+%{__ztsphp} -n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so -m | grep '^%{pecl_name}$'
%if %{with tests}
: Upstream test suite for ZTS extension
-TEST_PHP_EXECUTABLE=%{_bindir}/zts-php \
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php -q --show-diff
%endif
-popd
%endif
%files
-%{?_licensedir:%license NTS/LICENSE}
+%{?_licensedir:%license %{sources}/LICENSE}
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%config(noreplace) %{php_inidir}/%{ini_name}
@@ -213,6 +213,13 @@ popd
%changelog
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 1.6.0-2
+- rebuild for PHP 8.3.0RC1
+
+* Mon Aug 28 2023 Remi Collet <remi@remirepo.net> - 1.6.0-1
+- update to 1.6.0
+- build out of sources tree
+
* Thu Feb 9 2023 Remi Collet <remi@remirepo.net> - 1.5.3-1
- update to 1.5.3
- enable ZTS build