summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-06 11:36:51 +0100
committerRemi Collet <remi@remirepo.net>2017-12-06 11:36:51 +0100
commit7afd8bd2f9d29d75236d7814bb71da0b84cb34a8 (patch)
treed4fe101165c14d4367f87d8de435d2ef1c894234
parentb6362a2172b1c58c245ec08f0b9f385038a07e5f (diff)
cleanup
-rw-r--r--php-zendframework-zendxml.spec21
1 files changed, 8 insertions, 13 deletions
diff --git a/php-zendframework-zendxml.spec b/php-zendframework-zendxml.spec
index 6fe23d1..f5ea414 100644
--- a/php-zendframework-zendxml.spec
+++ b/php-zendframework-zendxml.spec
@@ -30,7 +30,6 @@ URL: https://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -78,8 +77,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}
cp -pr library/%{library} %{buildroot}%{php_home}/%{library}
@@ -101,23 +98,21 @@ Zend\Loader\AutoloaderFactory::factory(array(
)
));
EOF
-cd tests
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+cd tests
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md