summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-02-05 18:21:39 +0100
committerRemi Collet <fedora@famillecollet.com>2016-02-05 18:21:39 +0100
commit663407f305a5d7a2ec8fca22c22049639ae4e095 (patch)
tree3fabea094ed51c2656895913ef3c66fd6623b66f
parent7bc1c5b40667574e5659c613987ee0715b590bb8 (diff)
php-zendframework-zendxml: 1.0.2
-rw-r--r--php-zendframework-zendxml.spec25
1 files changed, 16 insertions, 9 deletions
diff --git a/php-zendframework-zendxml.spec b/php-zendframework-zendxml.spec
index 1d3c2c0..90cb23b 100644
--- a/php-zendframework-zendxml.spec
+++ b/php-zendframework-zendxml.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 54edb3875aba5b45f02824f65f311c9fb2743a38
+%global gh_commit 7b64507bc35d841c9c5802d67f6f87ef8e1a58c9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zendxml
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 1.0.1
+Version: 1.0.2
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -41,7 +41,7 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer, "require-dev": {
-# "phpunit/phpunit": "~3.7",
+# "phpunit/phpunit": "^3.7 || ^4.0",
# "squizlabs/php_codesniffer": "~1.5"
BuildRequires: php-composer(phpunit/phpunit) >= 3.7
# Autoloader
@@ -49,7 +49,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": ">=5.3.3"
+# "php": "^5.3.3 || ^7.0"
Requires: php(language) >= 5.3.3
# From phpcompatinfo report for version 1.0.1
Requires: php-simplexml
@@ -85,19 +85,23 @@ cp -pr library/%{library} %{buildroot}%{php_home}/%{library}
%check
%if %{with_tests}
mkdir vendor
-cat << EOF | tee vendor/autoload.php
+cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
-Zend\\Loader\\AutoloaderFactory::factory(array(
- 'Zend\\Loader\\StandardAutoloader' => array(
+Zend\Loader\AutoloaderFactory::factory(array(
+ 'Zend\Loader\StandardAutoloader' => array(
'namespaces' => array(
- 'ZendTest\\\\Xml' => dirname(__DIR__).'/tests/ZendXmlTest',
+ 'ZendTest\\Xml' => dirname(__DIR__).'/tests/ZendXmlTest',
'%{library}' => '%{buildroot}%{php_home}/%{library}'
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
cd tests
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
%else
: Test suite disabled
%endif
@@ -117,5 +121,8 @@ rm -rf %{buildroot}
%changelog
+* Fri Feb 5 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- update to 1.0.2
+
* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
-- initial package \ No newline at end of file
+- initial package