summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-14 11:07:13 +0200
committerRemi Collet <remi@remirepo.net>2018-05-14 11:07:13 +0200
commit1e528d9e33c29d627fac4640f210c0f500030ea9 (patch)
tree745962b10a5d7820f01cbad5f2bd110912e85c00
parent73b22f52b38bf6974f16d627a5a925292efa4b65 (diff)
-rw-r--r--composer.json51
-rw-r--r--php-zendframework-zendservice-recaptcha-pr12.patch33
-rw-r--r--php-zendframework-zendservice-recaptcha.spec17
3 files changed, 43 insertions, 58 deletions
diff --git a/composer.json b/composer.json
index 2a53f91..fb02219 100644
--- a/composer.json
+++ b/composer.json
@@ -1,22 +1,18 @@
{
"name": "zendframework/zendservice-recaptcha",
"description": "OOP wrapper for the ReCaptcha web service",
- "type": "library",
+ "license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"recaptcha"
],
- "homepage": "http://packages.zendframework.com/",
- "license": "BSD-3-Clause",
- "autoload": {
- "psr-4": {
- "ZendService\\ReCaptcha\\": "src/"
- }
- },
- "autoload-dev": {
- "psr-4": {
- "ZendServiceTest\\ReCaptcha\\": "test/"
- }
+ "support": {
+ "issues": "https://github.com/zendframework/ZendService_ReCaptcha/issues",
+ "source": "https://github.com/zendframework/ZendService_ReCaptcha",
+ "rss": "https://github.com/zendframework/ZendService_ReCaptcha/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
"php": "^5.6 || ^7.0",
@@ -24,7 +20,7 @@
"zendframework/zend-json": "^2.6.1 || ^3.0"
},
"require-dev": {
- "phpunit/phpunit": "^5.7 || ^6.0",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
"zendframework/zend-coding-standard": "~1.0.0",
"zendframework/zend-config": "^2.0",
"zendframework/zend-validator": "^2.8.2"
@@ -32,10 +28,33 @@
"suggest": {
"zendframework/zend-validator": "~2.0, if using ReCaptcha's Mailhide API"
},
+ "autoload": {
+ "psr-4": {
+ "ZendService\\ReCaptcha\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendServiceTest\\ReCaptcha\\": "test/"
+ }
+ },
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
- "dev-master": "3.0-dev",
- "dev-develop": "3.1-dev"
+ "dev-master": "3.1.x-dev",
+ "dev-develop": "3.2.x-dev"
}
+ },
+ "scripts": {
+ "check": [
+ "@cs-check",
+ "@test"
+ ],
+ "cs-check": "phpcs",
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zendservice-recaptcha-pr12.patch b/php-zendframework-zendservice-recaptcha-pr12.patch
deleted file mode 100644
index 9d8d668..0000000
--- a/php-zendframework-zendservice-recaptcha-pr12.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From a72b6a337c7567fd8825e3b3fcd571a117dfc4f8 Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Thu, 2 Mar 2017 08:44:42 +0100
-Subject: [PATCH] tag online tests to be able to easily skip them
-
----
- test/ReCaptchaTest.php | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/test/ReCaptchaTest.php b/test/ReCaptchaTest.php
-index f79937d..8fd4032 100644
---- a/test/ReCaptchaTest.php
-+++ b/test/ReCaptchaTest.php
-@@ -268,6 +268,9 @@ public function testVerifyWithMissingIp()
- $this->reCaptcha->verify('challenge', 'response');
- }
-
-+ /**
-+ * @group online
-+ */
- public function testVerifyWithMissingChallengeField()
- {
- $this->reCaptcha->setSecretKey($this->secretKey);
-@@ -276,6 +279,9 @@ public function testVerifyWithMissingChallengeField()
- $this->assertFalse($response->getStatus());
- }
-
-+ /**
-+ * @group online
-+ */
- public function testVerifyWithMissingResponseField()
- {
- $this->reCaptcha->setSecretKey($this->secretKey);
diff --git a/php-zendframework-zendservice-recaptcha.spec b/php-zendframework-zendservice-recaptcha.spec
index ccdafb3..13db3ce 100644
--- a/php-zendframework-zendservice-recaptcha.spec
+++ b/php-zendframework-zendservice-recaptcha.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6c6877c07c8ac73b187911ea5d264a640b234361
+%global gh_commit 8caf28e3ab8c18d75534c0741ccd6949347d20e8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project ZendService_ReCaptcha
@@ -17,8 +17,8 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{pk_project}
-Version: 3.0.0
-Release: 3%{?dist}
+Version: 3.1.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -27,9 +27,6 @@ URL: https://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-# See https://github.com/zendframework/ZendService_ReCaptcha/pull/12
-Patch0: %{name}-pr12.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -38,11 +35,11 @@ BuildRequires: php-json
BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^5.7 || ^6.0",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.5",
# "zendframework/zend-coding-standard": "~1.0.0",
# "zendframework/zend-config": "^2.0",
# "zendframework/zend-validator": "^2.8.2"
-BuildRequires: php-composer(phpunit/phpunit) >= 5.7
+BuildRequires: php-composer(phpunit/phpunit) >= 5.7.27
BuildRequires: php-composer(%{gh_owner}/zend-config) >= 2.0
BuildRequires: php-composer(%{gh_owner}/zend-validator) >= 2.8.2
# Autoloader
@@ -75,7 +72,6 @@ Provides: php-composer(%{gh_owner}/%{pk_project}) = %{version}
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -140,6 +136,9 @@ exit $ret
%changelog
+* Mon May 14 2018 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- update to 3.1.0
+
* Thu Mar 2 2017 Remi Collet <remi@fedoraproject.org> - 3.0.0-3
- add patch to skip online tests, from
https://github.com/zendframework/ZendService_ReCaptcha/pull/12