summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-06 11:46:20 +0100
committerRemi Collet <remi@remirepo.net>2017-12-06 11:46:20 +0100
commit0a61af0fc1d74dc987d44677c1663f4eb00a31c2 (patch)
tree8674604bca5e2e60b4910aee713d039112b267ac
parentde00569517245907341b9aa7857e0b2bad0ca4cf (diff)
-rw-r--r--.gitignore8
-rw-r--r--php-zendframework-zendpdf.spec28
2 files changed, 14 insertions, 22 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-zendframework-zendpdf.spec b/php-zendframework-zendpdf.spec
index 90a4af7..4effd3f 100644
--- a/php-zendframework-zendpdf.spec
+++ b/php-zendframework-zendpdf.spec
@@ -25,7 +25,6 @@ URL: https://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -93,8 +92,6 @@ ln -s ../Zend/autoload.php library/ZendPdf/autoload.php
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}
cp -pr library/%{library} %{buildroot}%{php_home}/%{library}
@@ -114,34 +111,21 @@ Zend\\Loader\\AutoloaderFactory::factory(array(
'ZendTest\\\\%{library}' => dirname(__DIR__).'/tests/ZendXmlTest'
))));
EOF
+
cd tests
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md