summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-15 08:42:52 +0200
committerRemi Collet <remi@remirepo.net>2018-05-15 08:42:52 +0200
commitc9806db1dc5046b1e12f41c441419d9fb8b3cae0 (patch)
tree23fea9e48d5973611473f7e01095e4b1baf65325
parent102e1feac224135acd8d424b38e22c09b4e66d36 (diff)
update to 2.7.0
use range dependencies on F27+ switch to phpunit6 or phpunit7
-rw-r--r--composer.json56
-rw-r--r--php-zendframework-zend-xmlrpc.spec66
2 files changed, 81 insertions, 41 deletions
diff --git a/composer.json b/composer.json
index 8bca64b..65f3815 100644
--- a/composer.json
+++ b/composer.json
@@ -1,25 +1,19 @@
{
"name": "zendframework/zend-xmlrpc",
- "description": " ",
+ "description": "Fully-featured XML-RPC server and client implementations",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"xmlrpc"
],
- "homepage": "https://github.com/zendframework/zend-xmlrpc",
- "autoload": {
- "psr-4": {
- "Zend\\XmlRpc\\": "src/"
- }
- },
- "autoload-dev": {
- "psr-4": {
- "ZendTest\\XmlRpc\\": "test/"
- },
- "files": [
- "test/autoload.php",
- "test/TestAsset/functions.php"
- ]
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-xmlrpc/",
+ "issues": "https://github.com/zendframework/zend-xmlrpc/issues",
+ "source": "https://github.com/zendframework/zend-xmlrpc",
+ "rss": "https://github.com/zendframework/zend-xmlrpc/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
"php": "^5.6 || ^7.0",
@@ -30,18 +24,33 @@
"zendframework/zendxml": "^1.0.2"
},
"require-dev": {
- "phpunit/PHPUnit": "^5.7.25 || ^6.4.4",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.2",
"zendframework/zend-coding-standard": "~1.0.0"
},
"suggest": {
"zendframework/zend-cache": "To support Zend\\XmlRpc\\Server\\Cache usage"
},
- "minimum-stability": "dev",
- "prefer-stable": true,
+ "autoload": {
+ "psr-4": {
+ "Zend\\XmlRpc\\": "src/"
+ }
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ZendTest\\XmlRpc\\": "test/"
+ },
+ "files": [
+ "test/autoload.php",
+ "test/TestAsset/functions.php"
+ ]
+ },
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
- "dev-master": "2.6-dev",
- "dev-develop": "2.7-dev"
+ "dev-master": "2.7.x-dev",
+ "dev-develop": "2.8.x-dev"
}
},
"scripts": {
@@ -49,10 +58,9 @@
"@cs-check",
"@test"
],
- "upload-coverage": "coveralls -v",
"cs-check": "phpcs",
"cs-fix": "phpcbf",
- "test": "phpunit",
- "test-coverage": "phpunit --coverage-clover clover.xml"
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-xmlrpc.spec b/php-zendframework-zend-xmlrpc.spec
index 9b351ea..19973b8 100644
--- a/php-zendframework-zend-xmlrpc.spec
+++ b/php-zendframework-zend-xmlrpc.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-xmlrpc
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 5470f555b336b48fe22db52df973c786a4a146d7
+%global gh_commit 97e7d70d71b040c8fc94807a911ee9a53dc35ef5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-xmlrpc
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.2
+Version: 2.7.0
Release: 2%{?dist}
Summary: Zend Framework %{library} component
@@ -42,15 +42,33 @@ BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-xmlwriter
+# From composer, "require-dev": {
+# "phpunit/PHPUnit": "^5.7.27 || ^6.5.8 || ^7.1.2",
+# "zendframework/zend-coding-standard": "~1.0.0"
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-http) >= 2.5.4 with php-autoloader(%{gh_owner}/zend-http) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-math) >= 2.7 with php-autoloader(%{gh_owner}/zend-math) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-server) >= 2.7 with php-autoloader(%{gh_owner}/zend-server) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zendxml) >= 1.0.2 with php-autoloader(%{gh_owner}/zendxml) < 2)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.2
+# remirepo:14
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-http) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-http) >= 2.5.4
+BuildRequires: php-autoloader(%{gh_owner}/zend-math) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-math) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-server) < 3
BuildRequires: php-autoloader(%{gh_owner}/zend-server) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
BuildRequires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+BuildRequires: php-autoloader(%{gh_owner}/zendxml) < 2
BuildRequires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
-# From composer, "require-dev": {
-# "phpunit/PHPUnit": "^5.7.25 || ^6.4.4",
-# "zendframework/zend-coding-standard": "~1.0.0"
-BuildRequires: phpunit6 >= 6.4.4
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -64,22 +82,30 @@ BuildRequires: php-fedora-autoloader-devel
# "zendframework/zendxml": "^1.0.2"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-http) >= 2.5.4
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-http) >= 2.5.4 with php-autoloader(%{gh_owner}/zend-http) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-math) >= 2.7 with php-autoloader(%{gh_owner}/zend-math) < 4)
+Requires: (php-autoloader(%{gh_owner}/zend-server) >= 2.7 with php-autoloader(%{gh_owner}/zend-server) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7 with php-autoloader(%{gh_owner}/zend-stdlib) < 4)
+Requires: (php-autoloader(%{gh_owner}/zendxml) >= 1.0.2 with php-autoloader(%{gh_owner}/zendxml) < 2)
+# remirepo:12
+%else
Requires: php-autoloader(%{gh_owner}/zend-http) < 3
-Requires: php-autoloader(%{gh_owner}/zend-math) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-http) >= 2.5.4
Requires: php-autoloader(%{gh_owner}/zend-math) < 4
-Requires: php-autoloader(%{gh_owner}/zend-server) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-math) >= 2.7
Requires: php-autoloader(%{gh_owner}/zend-server) < 3
-Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
+Requires: php-autoloader(%{gh_owner}/zend-server) >= 2.7
Requires: php-autoloader(%{gh_owner}/zend-stdlib) < 4
-Requires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
+Requires: php-autoloader(%{gh_owner}/zend-stdlib) >= 2.7
Requires: php-autoloader(%{gh_owner}/zendxml) < 2
+Requires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
+%endif
# From composer, "suggest": {
# "zendframework/zend-cache": "To support Zend\\XmlRpc\\Server\\Cache usage"
-%if 0%{?fedora} >= 21
Suggests: php-autoloader(%{gh_owner}/zend-cache)
%endif
-%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 2.5.2
@@ -150,9 +176,10 @@ require_once 'test/TestAsset/functions.php';
EOF
ret=0
-for cmd in php php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --include-path=%{buildroot}%{php_home} || ret=1
+for cmdarg in "php %{phpunit}" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -170,6 +197,11 @@ exit $ret
%changelog
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 2.7.0-1
+- update to 2.7.0
+- use range dependencies on F27+
+- switch to phpunit6 or phpunit7
+
* Fri Jan 26 2018 Remi Collet <remi@remirepo.net> - 2.6.2-1
- Update to 2.6.2
- switch to phpunit6