summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-05 14:35:13 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-05 14:35:13 +0200
commit7bd7645e1ce9bac996697b9baf4be1110c19d479 (patch)
treef493201967b8bfd300d069e3d25e6257cb36d2da
php-zendframework-zend-xmlrpc: 2.5.1 (new, wip)
-rw-r--r--Makefile3
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-zendframework-zend-xmlrpc.spec162
3 files changed, 192 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..a2cd659
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..24fbf81
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-zendframework-zend-xmlrpc.spec b/php-zendframework-zend-xmlrpc.spec
new file mode 100644
index 0000000..5ed9ffc
--- /dev/null
+++ b/php-zendframework-zend-xmlrpc.spec
@@ -0,0 +1,162 @@
+# remirepo spec/Fedora file for php-zendframework-zend-xmlrpc
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 118a6776016e9e2c449faae6bb917700e056be28
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner zendframework
+%global gh_project zend-xmlrpc
+%global php_home %{_datadir}/php
+%global library XmlRpc
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.5.1
+Release: 1%{?dist}
+Summary: Zend Framework %{library} component
+
+Group: Development/Libraries
+License: BSD
+URL: http://framework.zend.com/
+Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+BuildRequires: php(language) >= 5.3.23
+BuildRequires: php-simplexml
+BuildRequires: php-date
+BuildRequires: php-dom
+BuildRequires: php-iconv
+BuildRequires: php-libxml
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-xmlwriter
+BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-server) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+BuildRequires: php-composer(%{gh_owner}/zendxml) >= 1
+# From composer, "require-dev": {
+# "fabpot/php-cs-fixer": "1.7.*",
+# "phpunit/PHPUnit": "~4.0",
+# "zendframework/zend-servicemanager": "~2.5"
+BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.5
+BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# Autoloader
+BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
+%endif
+
+# From composer, "require": {
+# "php": ">=5.3.23",
+# "zendframework/zend-http": "~2.5",
+# "zendframework/zend-math": "~2.5",
+# "zendframework/zend-server": "~2.5",
+# "zendframework/zend-stdlib": "~2.5",
+# "zendframework/zendxml": "1.*"
+Requires: php(language) >= 5.3.23
+Requires: php-ldap
+%if ! %{bootstrap}
+Requires: php-composer(%{gh_owner}/zend-http) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-http) < 3
+Requires: php-composer(%{gh_owner}/zend-math) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-math) < 3
+Requires: php-composer(%{gh_owner}/zend-server) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-server) < 3
+Requires: php-composer(%{gh_owner}/zend-stdlib) >= 2.5
+Requires: php-composer(%{gh_owner}/zend-stdlib) < 3
+Requires: php-composer(%{gh_owner}/zendxml) >= 1
+Requires: php-composer(%{gh_owner}/zendxml) < 2
+# From composer, "suggest": {
+# "zendframework/zend-cache": "To support Zend\\XmlRpc\\Server\\Cache usage"
+%if 0%{?fedora} >= 21
+Suggests: php-composer(%{gh_owner}/zend-cache)
+%endif
+%endif
+# From phpcompatinfo report for version 2.5.2
+Requires: php-simplexml
+Requires: php-date
+Requires: php-dom
+Requires: php-iconv
+Requires: php-libxml
+Requires: php-pcre
+Requires: php-spl
+Requires: php-xmlwriter
+
+Obsoletes: php-ZendFramework2-%{library} < 2.5
+Provides: php-ZendFramework2-%{library} = %{version}
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+From its home page, XML-RPC is described as a ”...remote procedure calling
+using HTTP as the transport and XML as the encoding. XML-RPC is designed
+to be as simple as possible, while allowing complex data structures to be
+transmitted, processed and returned.”
+
+Zend\XmlRpc provides support for both consuming remote XML-RPC services and
+building new XML-RPC servers.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Empty build section, nothing required
+
+
+%install
+rm -rf %{buildroot}
+
+mkdir -p %{buildroot}%{php_home}/Zend/
+cp -pr src %{buildroot}%{php_home}/Zend/%{library}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << EOF | tee vendor/autoload.php
+<?php
+require_once '%{php_home}/Zend/Loader/AutoloaderFactory.php';
+Zend\\Loader\\AutoloaderFactory::factory(array(
+ 'Zend\\Loader\\StandardAutoloader' => array(
+ 'namespaces' => array(
+ 'ZendTest\\\\%{library}' => dirname(__DIR__).'/test/',
+ 'Zend\\\\%{library}' => '%{buildroot}%{php_home}/Zend/%{library}'
+))));
+require_once '%{php_home}/Zend/autoload.php';
+EOF
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+%else
+: Test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.md
+%doc CONTRIBUTING.md README.md
+%doc composer.json
+%{php_home}/Zend/%{library}
+
+
+%changelog
+* Tue Aug 4 2015 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- initial package \ No newline at end of file