summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-02 11:18:38 +0200
committerRemi Collet <remi@remirepo.net>2018-05-02 11:18:38 +0200
commitdc35b76c33e36de602609b2e3ee5f58109d4be63 (patch)
tree3b29cf13b41a600f49108d62eb3ad88a86675961
parent5adc127d8d325159ba7567401f67741cab3e0979 (diff)
update to 3.1.1
use range dependencies switch to phpunit7
-rw-r--r--composer.json37
-rw-r--r--php-zendframework-zend-xml2json.spec45
2 files changed, 54 insertions, 28 deletions
diff --git a/composer.json b/composer.json
index 350ab8e..c416233 100644
--- a/composer.json
+++ b/composer.json
@@ -3,19 +3,18 @@
"description": "Provides functionality for converting XML to JSON, optionally including XML attributes",
"license": "BSD-3-Clause",
"keywords": [
- "zf2",
+ "zf",
+ "zendframework",
"json",
"xml"
],
- "homepage": "https://github.com/zendframework/zend-xml2json",
- "config": {
- "sort-packages": true
- },
- "extra": {
- "branch-alias": {
- "dev-master": "3.0-dev",
- "dev-develop": "3.1-dev"
- }
+ "support": {
+ "docs": "https://docs.zendframework.com/zend-xml2json/",
+ "issues": "https://github.com/zendframework/zend-xml2json/issues",
+ "source": "https://github.com/zendframework/zend-xml2json",
+ "rss": "https://github.com/zendframework/zend-xml2json/releases.atom",
+ "chat": "https://zendframework-slack.herokuapp.com",
+ "forum": "https://discourse.zendframework.com/c/questions/components"
},
"require": {
"php": "^5.6 || ^7.0",
@@ -23,7 +22,7 @@
"zendframework/zendxml": "^1.0.2"
},
"require-dev": {
- "phpunit/phpunit": "^5.7.22 || ^6.4.1",
+ "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
"zendframework/zend-coding-standard": "~1.0.0"
},
"autoload": {
@@ -36,15 +35,23 @@
"ZendTest\\Xml2Json\\": "test/"
}
},
+ "config": {
+ "sort-packages": true
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.1.x-dev",
+ "dev-develop": "3.2.x-dev"
+ }
+ },
"scripts": {
"check": [
"@cs-check",
"@test"
],
- "upload-coverage": "coveralls",
"cs-check": "phpcs",
- "cs-fix": "phpcbf fix -v",
- "test": "phpunit",
- "test-coverage": "phpunit --coverage-clover clover.xml"
+ "cs-fix": "phpcbf",
+ "test": "phpunit --colors=always",
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-xml2json.spec b/php-zendframework-zend-xml2json.spec
index 2235b20..1236060 100644
--- a/php-zendframework-zend-xml2json.spec
+++ b/php-zendframework-zend-xml2json.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-xml2json
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 18fe365ea1355a4b220db8e98ccdc62c0bed18f5
+%global gh_commit 1fd6e09dfc3e9de5e873afc4fcadd541a15a4572
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-xml2json
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.1.0
-Release: 2%{?dist}
+Version: 3.1.1
+Release: 1%{?dist}
Summary: Provides functionality for converting XML to JSON
Group: Development/Libraries
@@ -36,17 +36,24 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
-BuildRequires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
# From composer, "require-dev": {
-# "phpunit/phpunit": "^5.7.22 || ^6.4.1",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
# "zendframework/zend-coding-standard": "~1.0.0"
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-json) < 4)
+BuildRequires: (php-autoloader(%{gh_owner}/zendxml) >= 1.0.2 with php-autoloader(%{gh_owner}/zendxml) < 2)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:8
%else
-%global phpunit %{_bindir}/phpunit
+BuildRequires: php-autoloader(%{gh_owner}/zend-json) < 4
+BuildRequires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
+BuildRequires: php-autoloader(%{gh_owner}/zendxml) < 2
+BuildRequires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
%endif
-BuildRequires: %{phpunit}
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -57,11 +64,18 @@ BuildRequires: php-fedora-autoloader-devel
# "zendframework/zendxml": "^1.0.2"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-json) >= 2.6.1 with php-autoloader(%{gh_owner}/zend-json) < 4)
+Requires: (php-autoloader(%{gh_owner}/zendxml) >= 1.0.2 with php-autoloader(%{gh_owner}/zendxml) < 2)
+# remirepo:6
+%else
Requires: php-autoloader(%{gh_owner}/zend-json) >= 2.6.1
Requires: php-autoloader(%{gh_owner}/zend-json) < 4
Requires: php-autoloader(%{gh_owner}/zendxml) >= 1.0.2
Requires: php-autoloader(%{gh_owner}/zendxml) < 2
%endif
+%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
# From phpcompatinfo report for version 3.0.0
@@ -111,10 +125,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" php71 php72; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -132,6 +146,11 @@ exit $ret
%changelog
+* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 3.1.1-1
+- update to 3.1.1
+- use range dependencies
+- switch to phpunit7
+
* Wed Dec 6 2017 Remi Collet <remi@remirepo.net> - 3.1.0-2
- switch from zend-loader to fedora/autoloader