summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-17 09:23:03 +0200
committerRemi Collet <remi@remirepo.net>2017-10-17 09:23:03 +0200
commit83e0ad93aa72de70b6ab49fb65c9f52a94eee6a5 (patch)
tree3da0d6174acb5db4e372f2bdd75ee7287b5677ba
parentd258ef3bca0d2a9d76d427e72e84579bd57c90fb (diff)
-rw-r--r--.gitignore8
-rw-r--r--composer.json9
-rw-r--r--php-zendframework-zend-xml2json.spec47
3 files changed, 40 insertions, 24 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/composer.json b/composer.json
index 50db5cc..350ab8e 100644
--- a/composer.json
+++ b/composer.json
@@ -8,6 +8,9 @@
"xml"
],
"homepage": "https://github.com/zendframework/zend-xml2json",
+ "config": {
+ "sort-packages": true
+ },
"extra": {
"branch-alias": {
"dev-master": "3.0-dev",
@@ -15,13 +18,13 @@
}
},
"require": {
- "php": "^5.5 || ^7.0",
+ "php": "^5.6 || ^7.0",
"zendframework/zend-json": "^2.6.1 || ^3.0",
"zendframework/zendxml": "^1.0.2"
},
"require-dev": {
- "squizlabs/php_codesniffer": "^2.3",
- "phpunit/PHPUnit": "~4.0"
+ "phpunit/phpunit": "^5.7.22 || ^6.4.1",
+ "zendframework/zend-coding-standard": "~1.0.0"
},
"autoload": {
"psr-4": {
diff --git a/php-zendframework-zend-xml2json.spec b/php-zendframework-zend-xml2json.spec
index 14bb4d4..795cb3d 100644
--- a/php-zendframework-zend-xml2json.spec
+++ b/php-zendframework-zend-xml2json.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d3af243557a3f681fc85c08473dca2318af74ab5
+%global gh_commit 18fe365ea1355a4b220db8e98ccdc62c0bed18f5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-xml2json
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.0.0
+Version: 3.1.0
Release: 1%{?dist}
Summary: Provides functionality for converting XML to JSON
@@ -30,28 +30,32 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
-BuildRequires: php(language) >= 5.5
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
BuildRequires: php-composer(%{gh_owner}/zendxml) >= 1.0.2
# From composer, "require-dev": {
-# "squizlabs/php_codesniffer": "^2.3",
-# "phpunit/PHPUnit": "~4.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "phpunit/phpunit": "^5.7.22 || ^6.4.1",
+# "zendframework/zend-coding-standard": "~1.0.0"
+%if 0%{?fedora} >= 26
+%global phpunit %{_bindir}/phpunit6
+%else
+%global phpunit %{_bindir}/phpunit
+%endif
+BuildRequires: %{phpunit}
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
# From composer, "require": {
-# "php": "^5.5 || ^7.0",
+# "php": "^5.6 || ^7.0",
# "zendframework/zend-json": "^2.6.1 || ^3.0",
# "zendframework/zendxml": "^1.0.2"
-Requires: php(language) >= 5.5
+Requires: php(language) >= 5.6
%if ! %{bootstrap}
Requires: php-composer(%{gh_owner}/zend-json) >= 2.6.1
Requires: php-composer(%{gh_owner}/zend-json) < 4
@@ -83,8 +87,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -104,22 +106,20 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+ret=0
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -128,6 +128,11 @@ rm -rf %{buildroot}
%changelog
+* Tue Oct 17 2017 Remi Collet <remi@remirepo.net> - 3.1.0-1
+- Update to 3.1.0
+- raise dependency on PHP 5.6
+- use phpunit6 on F26+
+
* Wed Jun 29 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
- initial package