summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-12 13:36:44 +0100
committerRemi Collet <remi@remirepo.net>2017-12-12 13:36:44 +0100
commit6f4c180d26a8e44fd272f310897b66c5adbcab35 (patch)
tree5d0fc3eb8f278953532a5d264532dd92fd938be4
parentf2bed1bb9c739d1b51eb49982d5af07ab1024827 (diff)
clean
-rw-r--r--.gitignore8
-rw-r--r--php-zendframework-zend-view.spec22
2 files changed, 13 insertions, 17 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-zendframework-zend-view.spec b/php-zendframework-zend-view.spec
index bfdc012..fb61cac 100644
--- a/php-zendframework-zend-view.spec
+++ b/php-zendframework-zend-view.spec
@@ -30,7 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -187,8 +186,6 @@ mv LICENSE.md LICENSE
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -217,28 +214,19 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-# remirepo:7
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit6 || ret=1
-fi
-%{phpunit} --verbose
-# remirepo:1
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md