summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-version.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-11 08:07:47 +0100
committerRemi Collet <remi@remirepo.net>2017-12-11 08:07:47 +0100
commit8156b72bad2d45cd6f9c8ad2826a4ae7fa99c01e (patch)
tree30ebfea08467dc7babee5ebbad8742b362d842f9 /php-zendframework-zend-version.spec
parent37ec2ea8f70e5d8602d4386f7f846dfc908f8e9f (diff)
Diffstat (limited to 'php-zendframework-zend-version.spec')
-rw-r--r--php-zendframework-zend-version.spec22
1 files changed, 9 insertions, 13 deletions
diff --git a/php-zendframework-zend-version.spec b/php-zendframework-zend-version.spec
index 43ad0b8..665189d 100644
--- a/php-zendframework-zend-version.spec
+++ b/php-zendframework-zend-version.spec
@@ -30,7 +30,6 @@ URL: https://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -79,14 +78,14 @@ for example.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+mv LICENSE.md LICENSE
+
%build
# Empty build section, nothing required
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{php_home}/Zend/
cp -pr src %{buildroot}%{php_home}/Zend/%{library}
@@ -106,22 +105,19 @@ Zend\\Loader\\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-fi
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit || ret=1
+ fi
+done
+exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md