summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
committerRemi Collet <fedora@famillecollet.com>2015-11-19 08:29:42 +0100
commited060df0e96907465736e1f6b7d4b732e49c163a (patch)
tree70d38b241c0aefad07a616505cace487b4516e40
parent2eebb47ac66005d10e3d518d65a2bc11767528f5 (diff)
php-zendframework-zend-*: run test suite with PHP 7 when available
-rw-r--r--php-zendframework-zend-validator.spec5
1 files changed, 5 insertions, 0 deletions
diff --git a/php-zendframework-zend-validator.spec b/php-zendframework-zend-validator.spec
index 0b86ef9..34c79d3 100644
--- a/php-zendframework-zend-validator.spec
+++ b/php-zendframework-zend-validator.spec
@@ -147,7 +147,12 @@ Zend\Loader\AutoloaderFactory::factory(array(
))));
require_once '%{php_home}/Zend/autoload.php';
EOF
+
%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+
+if which php70; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+fi
%else
: Test suite disabled
%endif