summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-15 14:21:43 +0200
committerRemi Collet <remi@remirepo.net>2017-08-15 14:21:43 +0200
commite9dc135cd88f40ec3dbbc54cfac7274c65674cf4 (patch)
tree1b7e4270b3a1e4f51af0907a437047704747535f
parent5b70506cf318282378a5b2c750d36df16f7c43e5 (diff)
v2.10.0
-rw-r--r--composer.json8
-rw-r--r--php-zendframework-zend-validator-pr190.patch28
-rw-r--r--php-zendframework-zend-validator.spec17
3 files changed, 12 insertions, 41 deletions
diff --git a/composer.json b/composer.json
index 560ed56..a65cf39 100644
--- a/composer.json
+++ b/composer.json
@@ -26,7 +26,7 @@
"zendframework/zend-i18n": "^2.6",
"zendframework/zend-math": "^2.6",
"zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
- "zendframework/zend-session": "^2.6.2",
+ "zendframework/zend-session": "^2.8",
"zendframework/zend-uri": "^2.5",
"phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
"zendframework/zend-coding-standard": "~1.0.0"
@@ -38,15 +38,15 @@
"zendframework/zend-math": "Zend\\Math component, required by the Csrf validator",
"zendframework/zend-i18n-resources": "Translations of validator messages",
"zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
- "zendframework/zend-session": "Zend\\Session component, required by the Csrf validator",
+ "zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
"zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
},
"minimum-stability": "dev",
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.9-dev",
- "dev-develop": "2.10-dev"
+ "dev-master": "2.10-dev",
+ "dev-develop": "2.11-dev"
},
"zf": {
"component": "Zend\\Validator",
diff --git a/php-zendframework-zend-validator-pr190.patch b/php-zendframework-zend-validator-pr190.patch
deleted file mode 100644
index 1d46933..0000000
--- a/php-zendframework-zend-validator-pr190.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 61969df070bbfa3e889b253738828064b8ff211b Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Fri, 4 Aug 2017 09:59:14 +0200
-Subject: [PATCH] fix for PHP 7.2, count(): Parameter must be an array or an
- object that implements Countable
-
----
- src/File/Upload.php | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/src/File/Upload.php b/src/File/Upload.php
-index 55025f63..b03dc4a6 100644
---- a/src/File/Upload.php
-+++ b/src/File/Upload.php
-@@ -109,10 +109,10 @@ public function getFiles($file = null)
- */
- public function setFiles($files = [])
- {
-- if (count($files) === 0) {
-- $this->options['files'] = $_FILES;
-- } else {
-+ if (is_array($files) && count($files) > 0) {
- $this->options['files'] = $files;
-+ } else {
-+ $this->options['files'] = $_FILES;
- }
-
- if ($this->options['files'] === null) {
diff --git a/php-zendframework-zend-validator.spec b/php-zendframework-zend-validator.spec
index 2c0d8ab..9bc8c24 100644
--- a/php-zendframework-zend-validator.spec
+++ b/php-zendframework-zend-validator.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a58dbe8463b93de0d650e296d56cb7da4a129ff3
+%global gh_commit 07ef29e31353592e99eb32b2feb7248681ffb630
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-validator
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.9.2
+Version: 2.10.0
Release: 1%{?dist}
Summary: Zend Framework %{library} component
@@ -30,9 +30,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-# https://github.com/zendframework/zend-validator/pull/190
-Patch0: %{name}-pr190.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -55,7 +52,7 @@ BuildRequires: php-composer(container-interop/container-interop) >= 1.1
# "zendframework/zend-i18n": "^2.6",
# "zendframework/zend-math": "^2.6",
# "zendframework/zend-servicemanager": "^2.7.5 || ^3.0.3",
-# "zendframework/zend-session": "^2.6.2",
+# "zendframework/zend-session": "^2.8",
# "zendframework/zend-uri": "^2.5",
# "phpunit/PHPUnit": "^6.0.8 || ^5.7.15",
# "zendframework/zend-coding-standard": "~1.0.0"
@@ -67,7 +64,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-http) >= 2.5.4
BuildRequires: php-composer(%{gh_owner}/zend-i18n) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
-BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.6.2
+BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.8
BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
%if 0%{?fedora} >= 26
%global phpunit %{_bindir}/phpunit6
@@ -96,7 +93,7 @@ Requires: php-composer(container-interop/container-interop) < 2
# "zendframework/zend-math": "Zend\\Math component, required by the Csrf validator",
# "zendframework/zend-i18n-resources": "Translations of validator messages",
# "zendframework/zend-servicemanager": "Zend\\ServiceManager component to allow using the ValidatorPluginManager and validator chains",
-# "zendframework/zend-session": "Zend\\Session component, required by the Csrf validator",
+# "zendframework/zend-session": "Zend\\Session component, ^2.8; required by the Csrf validator",
# "zendframework/zend-uri": "Zend\\Uri component, required by the Uri and Sitemap\\Loc validators"
%if 0%{?fedora} >= 21
Suggests: php-composer(%{gh_owner}/zend-db)
@@ -133,7 +130,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
mv LICENSE.md LICENSE
@@ -186,6 +182,9 @@ exit $ret
%changelog
+* Tue Aug 15 2017 Remi Collet <remi@remirepo.net> - 2.10.0-1
+- Update to 2.10.0
+
* Fri Aug 4 2017 Remi Collet <remi@remirepo.net> - 2.9.2-1
- Update to 2.9.2
- add patch for PHP 7.2 from