summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-31 07:55:40 +0100
committerRemi Collet <remi@remirepo.net>2017-10-31 07:55:40 +0100
commit2f8ebdc3304e5d8bf3f240ebe636fb6e1d48b786 (patch)
tree93331574c1a6d0cfb8556c2bcaa1b53a0a36f2c1
parent4db02eb673ce396ef41c47a1be0ccac1982929ca (diff)
fix FTBFS from Koschei, add patch for test with 7.2 from https://github.com/zendframework/zend-validator/pull/205
-rw-r--r--205.patch24
-rw-r--r--php-zendframework-zend-validator.spec11
2 files changed, 33 insertions, 2 deletions
diff --git a/205.patch b/205.patch
new file mode 100644
index 0000000..f2bf9d8
--- /dev/null
+++ b/205.patch
@@ -0,0 +1,24 @@
+From d5130afc45c09f953ee10999df7eb419dcc8e7a9 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 31 Oct 2017 07:46:56 +0100
+Subject: [PATCH] Fix #196 don't test deprecated abbreviations
+
+---
+ test/TimezoneTest.php | 3 ---
+ 1 file changed, 3 deletions(-)
+
+diff --git a/test/TimezoneTest.php b/test/TimezoneTest.php
+index d9c3a0ff..7488ee36 100644
+--- a/test/TimezoneTest.php
++++ b/test/TimezoneTest.php
+@@ -117,10 +117,7 @@ public function testAbbreviationsByTypeAsString($value, $valid)
+ public function abbreviationProvider()
+ {
+ return [
+- ['bnt', true], // Brunei Darussalam Time
+ ['cest', true], // Central European Summer Time
+- ['easst', true], // Easter Island Summer Time
+- ['egst', true], // Eastern Greenland Summer Time
+ ['hkt', true], // Hong Kong Time
+ ['nzdt', true], // New Zealand Daylight Time
+ ['sast', true], // South Africa Standard Time
diff --git a/php-zendframework-zend-validator.spec b/php-zendframework-zend-validator.spec
index 4a02e39..d5173ce 100644
--- a/php-zendframework-zend-validator.spec
+++ b/php-zendframework-zend-validator.spec
@@ -21,7 +21,7 @@
Name: php-%{gh_owner}-%{gh_project}
Version: 2.10.1
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -30,6 +30,8 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
+Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-validator/pull/205.patch
+
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -130,6 +132,7 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1 -b .pr205
mv LICENSE.md LICENSE
@@ -162,7 +165,7 @@ EOF
# PHP 7.2 https://github.com/zendframework/zend-validator/issues/196
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71; do
+for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -183,6 +186,10 @@ exit $ret
%changelog
+* Tue Oct 31 2017 Remi Collet <remi@remirepo.net> - 2.10.1-2
+- fix FTBFS from Koschei, add patch for test with 7.2 from
+ https://github.com/zendframework/zend-validator/pull/205
+
* Wed Aug 23 2017 Remi Collet <remi@remirepo.net> - 2.10.1-1
- Update to 2.10.1