summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-02 06:43:48 +0100
committerRemi Collet <remi@remirepo.net>2018-02-02 06:43:48 +0100
commit0b8ac35ff546cacd4b5b6880b0a553dda935011c (patch)
treead692becb6e7f93810e87d6f341568ba264ae458
parent4543f9bed127682e167f302d799df060331daaab (diff)
Update to 2.10.2
switch to phpunit6
-rw-r--r--composer.json7
-rw-r--r--php-zendframework-zend-validator.spec29
2 files changed, 15 insertions, 21 deletions
diff --git a/composer.json b/composer.json
index a65cf39..17f2915 100644
--- a/composer.json
+++ b/composer.json
@@ -45,8 +45,8 @@
"prefer-stable": true,
"extra": {
"branch-alias": {
- "dev-master": "2.10-dev",
- "dev-develop": "2.11-dev"
+ "dev-master": "2.10.x-dev",
+ "dev-develop": "2.11.x-dev"
},
"zf": {
"component": "Zend\\Validator",
@@ -66,7 +66,6 @@
"cs-check": "phpcs",
"cs-fix": "phpcbf",
"test": "phpunit --colors=always",
- "test-coverage": "phpunit --colors=always --coverage-clover clover.xml",
- "upload-coverage": "coveralls -v"
+ "test-coverage": "phpunit --colors=always --coverage-clover clover.xml"
}
}
diff --git a/php-zendframework-zend-validator.spec b/php-zendframework-zend-validator.spec
index 87c0d87..1abbd9a 100644
--- a/php-zendframework-zend-validator.spec
+++ b/php-zendframework-zend-validator.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-validator
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 010084ddbd33299bf51ea6f0e07f8f4e8bd832a8
+%global gh_commit 38109ed7d8e46cfa71bccbe7e6ca80cdd035f8c9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-validator
@@ -22,8 +22,8 @@
# TODO switch BR to fedora-autoloader + tests
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.10.1
-Release: 3%{?dist}
+Version: 2.10.2
+Release: 2%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -32,8 +32,6 @@ URL: https://zendframework.github.io/%{gh_project}/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
-Patch0: https://patch-diff.githubusercontent.com/raw/zendframework/zend-validator/pull/205.patch
-
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -70,12 +68,7 @@ BuildRequires: php-composer(%{gh_owner}/zend-math) >= 2.6
BuildRequires: php-composer(%{gh_owner}/zend-servicemanager) >= 2.7.5
BuildRequires: php-composer(%{gh_owner}/zend-session) >= 2.8
BuildRequires: php-composer(%{gh_owner}/zend-uri) >= 2.5
-%if 0%{?fedora} >= 26
-%global phpunit %{_bindir}/phpunit6
-%else
-%global phpunit %{_bindir}/phpunit
-%endif
-BuildRequires: %{phpunit}
+BuildRequires: phpunit6 >= 6.0.8
# Autoloader
BuildRequires: php-composer(%{gh_owner}/zend-loader) >= 2.5
%endif
@@ -138,7 +131,6 @@ Documentation: https://zendframework.github.io/%{gh_project}/
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1 -b .pr205
mv LICENSE.md LICENSE
@@ -185,10 +177,9 @@ EOF
# PHP 7.2 https://github.com/zendframework/zend-validator/issues/196
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72; do
- if which $cmdarg; then
- set $cmdarg
- $1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
+for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd -d memory_limit=1G %{_bindir}/phpunit6 --verbose || ret=1
fi
done
exit $ret
@@ -206,6 +197,10 @@ exit $ret
%changelog
+* Fri Feb 2 2018 Remi Collet <remi@remirepo.net> - 2.10.2-1
+- Update to 2.10.2
+- switch to phpunit6
+
* Thu Dec 7 2017 Remi Collet <remi@remirepo.net> - 2.10-1-3
- switch from zend-loader to fedora/autoloader