summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-uri.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-05-02 11:00:39 +0200
committerRemi Collet <remi@remirepo.net>2018-05-02 11:00:39 +0200
commit8d411c34c84089439854acb2d4aac3f3bf30fa40 (patch)
tree4c1931b615581e07d93eaee80c07bb1fd80a3ad2 /php-zendframework-zend-uri.spec
parent74f3ef0d271c8accef567328f4c8b4230987763b (diff)
update to 2.6.1
use range dependencies raise dependency on zend-validator 2.10 switch to phpunit7
Diffstat (limited to 'php-zendframework-zend-uri.spec')
-rw-r--r--php-zendframework-zend-uri.spec50
1 files changed, 38 insertions, 12 deletions
diff --git a/php-zendframework-zend-uri.spec b/php-zendframework-zend-uri.spec
index 907febb..13514e5 100644
--- a/php-zendframework-zend-uri.spec
+++ b/php-zendframework-zend-uri.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit fb998b9487ea8c5f4aaac0e536190709bdd5353b
+%global gh_commit 3b6463645c6766f78ce537c70cb4fdabee1e725f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-uri
@@ -20,7 +20,7 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.6.0
+Version: 2.6.1
Release: 2%{?dist}
Summary: Zend Framework %{library} component
@@ -36,12 +36,24 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-spl
-BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5
-BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.5
# From composer, "require-dev": {
-# "phpunit/phpunit": "^6.2.1 || ^5.7.15",
+# "phpunit/phpunit": "^5.7.27 || ^6.5.8 || ^7.1.4",
# "zendframework/zend-coding-standard": "~1.0.0"
-BuildRequires: phpunit6 >= 6.2.1
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.5 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
+BuildRequires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: phpunit7 >= 7.1.4
+# remirepo:8
+%else
+BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) < 3
+BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10
+%global phpunit %{_bindir}/phpunit6
+BuildRequires: phpunit6 >= 6.5.8
+%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
@@ -49,13 +61,20 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
# "zendframework/zend-escaper": "^2.5",
-# "zendframework/zend-validator": "^2.5"
+# "zendframework/zend-validator": "^2.10"
Requires: php(language) >= 5.6
%if ! %{bootstrap}
-Requires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-autoloader(%{gh_owner}/zend-escaper) >= 2.5 with php-autoloader(%{gh_owner}/zend-escaper) < 3)
+Requires: (php-autoloader(%{gh_owner}/zend-validator) >= 2.10 with php-autoloader(%{gh_owner}/zend-validator) < 3)
+# remirepo:6
+%else
Requires: php-autoloader(%{gh_owner}/zend-escaper) < 3
-Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.5
+Requires: php-autoloader(%{gh_owner}/zend-escaper) >= 2.5
Requires: php-autoloader(%{gh_owner}/zend-validator) < 3
+Requires: php-autoloader(%{gh_owner}/zend-validator) >= 2.10
+%endif
%endif
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -109,9 +128,10 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit6 --include-path=%{buildroot}%{php_home} || ret=1
+for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+ if which $cmdarg; then
+ set $cmdarg
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -129,6 +149,12 @@ exit $ret
%changelog
+* Wed May 2 2018 Remi Collet <remi@remirepo.net> - 2.6.1-2
+- update to 2.6.1
+- use range dependencies
+- raise dependency on zend-validator 2.10
+- switch to phpunit7
+
* Wed Apr 11 2018 Remi Collet <remi@remirepo.net> - 2.6.0-1
- update to 2.6.0
- raise dependency on PHP 5.6