summaryrefslogtreecommitdiffstats
path: root/php-zendframework-zend-test.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zendframework-zend-test.spec')
-rw-r--r--php-zendframework-zend-test.spec52
1 files changed, 38 insertions, 14 deletions
diff --git a/php-zendframework-zend-test.spec b/php-zendframework-zend-test.spec
index 7ab42ab..5c4feb2 100644
--- a/php-zendframework-zend-test.spec
+++ b/php-zendframework-zend-test.spec
@@ -1,13 +1,13 @@
# remirepo/Fedora spec file for php-zendframework-zend-test
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 9976fb519851276d56e201bc6211b3a94e6c3b19
+%global gh_commit 626606425072e9d513df3bf723913c0bb9d03f8c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner zendframework
%global gh_project zend-test
@@ -20,8 +20,8 @@
%endif
Name: php-%{gh_owner}-%{gh_project}
-Version: 3.1.1
-Release: 2%{?dist}
+Version: 3.2.0
+Release: 1%{?dist}
Summary: Zend Framework %{library} component
Group: Development/Libraries
@@ -36,6 +36,11 @@ BuildArch: noarch
BuildRequires: php(language) >= 5.6
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: phpunit6
+# remirepo:1
+%if 0%{?fedora} >= 26 || 0%{?rhel} >= 8
+BuildRequires: phpunit7
+# remirepo:1
+%endif
BuildRequires: php-pcre
BuildRequires: php-autoloader(%{gh_owner}/zend-console) >= 2.6
BuildRequires: php-autoloader(%{gh_owner}/zend-dom) >= 2.6
@@ -56,7 +61,7 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-view) >= 2.6.3
# "zendframework/zend-mvc-console": "^1.1.8",
# "zendframework/zend-mvc-plugin-flashmessenger": "^0.1.0",
# "zendframework/zend-serializer": "^2.6.1",
-# "zendframework/zend-session": "^2.6.2",
+# "zendframework/zend-session": "^2.8.5",
# "zendframework/zend-validator": "^2.8"
BuildRequires: php-composer(mikey179/vfsStream) >= 1.2
BuildRequires: php-symfony-finder
@@ -66,7 +71,7 @@ BuildRequires: php-autoloader(%{gh_owner}/zend-modulemanager) >= 2.7.1
BuildRequires: php-autoloader(%{gh_owner}/zend-mvc-console) >= 1.1.8
BuildRequires: php-autoloader(%{gh_owner}/zend-mvc-plugin-flashmessenger) >= 0.1.0
BuildRequires: php-autoloader(%{gh_owner}/zend-serializer) >= 2.6.1
-BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.6.2
+BuildRequires: php-autoloader(%{gh_owner}/zend-session) >= 2.8.5
BuildRequires: php-autoloader(%{gh_owner}/zend-validator) >= 2.8
%endif
# Autoloader
@@ -74,7 +79,7 @@ BuildRequires: php-fedora-autoloader-devel
# From composer, "require": {
# "php": "^5.6 || ^7.0",
-# "phpunit/phpunit": "^4.0 || ^5.0 || ^6.0",
+# "phpunit/phpunit": "^4.0 || ^5.0 || ^6.0 || ^7.0",
# "sebastian/version": "^1.0.4 || ^2.0",
# "zendframework/zend-console": "^2.6",
# "zendframework/zend-dom": "^2.6",
@@ -86,9 +91,15 @@ BuildRequires: php-fedora-autoloader-devel
# "zendframework/zend-uri": "^2.5",
# "zendframework/zend-view": "^2.6.3"
Requires: php(language) >= 5.6
-%if 0%{?fedora} >= 25
+# remirepo:1
+%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
+Recommends: phpunit7
+# remirepo:2
+%endif
+%if 0%{?fedora} >= 25 || 0%{?rhel} >= 8
Recommends: phpunit6
Recommends: php-composer(phpunit/phpunit) >= 4.0
+# remirepo:3
%else
Requires: php-composer(phpunit/phpunit) >= 4.0
%endif
@@ -198,16 +209,25 @@ require_once '%{buildroot}%{php_home}/Zend/%{library}/autoload.php';
EOF
ret=0
-for cmd in php php56 php70 php71 php72; do
- if which $cmd; then
- $cmd %{_bindir}/phpunit --verbose || ret=1
- fi
-done
for cmd in php php70 php71 php72; do
if which $cmd; then
- $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd %{_bindir}/phpunit --verbose || ret=1
fi
done
+if [ -f %{_bindir}/phpunit6 ]; then
+ for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+ done
+fi
+if [ -f %{_bindir}/phpunit7 ]; then
+ for cmd in php php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit7 --verbose || ret=1
+ fi
+ done
+fi
exit $ret
%else
: Test suite disabled
@@ -224,6 +244,10 @@ exit $ret
%changelog
+* Thu Apr 12 2018 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- update to 3.2.0
+- allow phpunit7
+
* Wed Dec 13 2017 Remi Collet <remi@remirepo.net> - 3.1.1-2
- switch from zend-loader to fedora/autoloader