summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-29 14:17:22 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-29 14:17:22 +0200
commita2d899fc96a69864062a4cc7dcd3be9903d8c00d (patch)
treec761c7bbac1a6f4d81520f9c4ae44e5d086aac25
parent7a07d7a6e32b3a360ed1c46bae221fc9a38e7cb2 (diff)
php-zendframework: 3.0.0
-rw-r--r--php-zendframework-zend-test.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php-zendframework-zend-test.spec b/php-zendframework-zend-test.spec
index e6a1e3f..7f04ea1 100644
--- a/php-zendframework-zend-test.spec
+++ b/php-zendframework-zend-test.spec
@@ -26,7 +26,7 @@ Summary: Zend Framework %{library} component
Group: Development/Libraries
License: BSD
-URL: http://framework.zend.com/
+URL: https://framework.zend.com/
Source0: %{gh_commit}/%{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
@@ -156,11 +156,22 @@ Zend\Loader\AutoloaderFactory::factory(array(
require_once '%{php_home}/Zend/autoload.php';
EOF
-%{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
-
-if which php70; then
- php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home}
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if which php71; then
+ php70 %{_bindir}/phpunit --include-path=%{buildroot}%{php_home} || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --include-path=%{buildroot}%{php_home} --verbose
+# remirepo:2
fi
+exit $ret
%else
: Test suite disabled
%endif